ArcGIS for Autocad: Right-click stops functioning

Jump to solution
02-06-2020 07:45 AM
New Contributor III

I have found a problem where my right-click in Autodesk Civil 3D 2019 stops working after I load a feature service in ArcGIS for Autocad 370.  Has anyone else experienced this?  It will work after I load up the ArcGIS for Autocad .dll file using NETLOAD.  It is only after connecting to a feature service the right-click stops functioning.  (Shift-right-click, however, still functions!)  Any help is appreciated.#arcgis for autocad 370  

Tags (1)
0 Kudos
12 Replies
New Contributor II

Hi Jen, thanks for sharing. Could you tell me which version of ArcGIS for AutoCAD are you using?

0 Kudos
by Anonymous User
Not applicable

Hi there - thanks for your reply!

A support ticket has been submitted for this.

We are using the ArcGIS for AutoCAD version 400 in our test environment.

The issue appears to be that we have configured both Online and Portal to use SAML ADFS for logins. Both 370 and 400 have issue with the adfs sign-in popup. If the user signs in using a "Built-In" user, there is no issue. 

Another work around that we are using is to sign in with a Built-In user.

New Contributor III

I solved my right-click problem by upgrading to AFA v400.  I hadn't done this previously because I was getting an error when I tried to install it.  I discovered that the Windows Installer Service wasn't functioning properly.  Our IT group helped me fix the installer service, then I was able to install AFA v400, which doesn't have the right-click problem (for me).  Yay!

Jen Parkhill, you most likely have a different problem since you tested AFA v400 and still have the issue.

The problem may be related to this article:

370 was released before ACAD 2020, so it wasn't designed to be compatible.  This may be true for 2019 too.

View solution in original post

0 Kudos