Taking map offline - error code 500: Unable to create replica. Please check your parameters

2087
9
04-26-2023 08:01 PM
elpinguino
Occasional Contributor III

Hi Field Mappers,

I'm writing in the forums hoping other people have come across this issue too (recently and solved it) without having to republish...

Problem:

I've added new fields, and now I'm not able to take the map offline.

The main error (I think?):

Error downloading map: Service error code 500: unable to create replica. Please check your parameters. Details: Exporting data for layer 32 failed. (Rest of the log attached)

So I've pinpointed the layer by going into the JSON. Based off of that I decided the other layers in the service are not the problem. I have also tested taking the other layers offline without layer 32. It worked. I tried adding layer 32 into its own map by itself and taking it offline. It didn't work.

I don't understand what's wrong with my parameters and how to fix them though. By parameters is that the feature service settings, Field Maps settings...?

I have also checked that I haven't added any fields using reserve words.

The feature service is live and people are using it, so I can't tinker (eg delete fields) too much with it, but am at the stage where I'm considering downloading it to FGDB, republishing and then removing each new field I added one by one, but am hoping someone might have a good work around for this?

These are older posts I found and tried, but didn't work for me.

 

Has anyone else come across this before and recently?

9 Replies
SamMeacham
New Contributor

We are experiencing the same issue. Hopefully someone out there has some idea which 'parameters' we need to be checking.

RonParis
Occasional Contributor

I've been having this issue also, and it appears to be becoming more and more frequent across multiple hosted feature services.

 

Unfortunately we are stabbing in the dark with this a little bit as there seems no obvious reason as to why downloading a map is failing. It worked one day and now it isn't

EddyClark
Occasional Contributor

I think I got mine to work.  Created a view of the layer and edited the map's JSON via ArcGIS Assistant pointing the troublesome layer to the view.  Cannot explain why this happened or why the view works over the main.  

0 Kudos
JoabelBarbieri
Occasional Contributor II

So frustrating...it happens every time....I update a layer and then offline sync, download stops and shows "download failed". Failed to create offline areas too on FMDesigner . Troubleshoot logs in FMA are as useless! 

0 Kudos
SBrandenburg
New Contributor III

We have this issue often when trying to take field maps offline and there seems to be little rhyme or reason for it. If someone comes up with a straightforward solution, it would be much appreciated!

0 Kudos
luckachi
Occasional Contributor III

We are currently experiencing this issue without any changes to the hosted feature layers or web map. Field season is gearing up so any resolution to this issue would be greatly appreciated!

0 Kudos
JohnMacDougall
New Contributor

I am running into this right now, all layers are set to go offline

0 Kudos
leahpfuller
New Contributor

We are having this issue across several field maps now too!

0 Kudos
DanielFox1
Esri Contributor

Hi 

We recommend checking if any of the data you are using is used in an Experience Builder along with Field Maps additional field indexes get created on those layers and then subsquently prevent the data from being downloaded for offline use. Please also see this community post about this

https://community.esri.com/t5/arcgis-field-maps-questions/cannot-download-offline-area-error-code-50...

If there is an index created with a hypen (-) I would remove it and try again.

0 Kudos