Arc Collector unable to create replica

965
4
04-14-2020 05:00 PM
Chattahoochee_-_OconeeNational
New Contributor II

When downloading a map for offline use in Collector the error forms "failed to download witht eh message: Unable to create replica. Please check your parameters., Exporting data for layer 0 failed." I have tried making a new map, made sure all the layers are available to edit and it still crashes

0 Kudos
4 Replies
Katherine_Clark
MVP Regular Contributor

I found this post and there are several possible solutions mentioned in the comments. The easiest one to try being:

I was having a similar issue. What worked for me was going into the web map details, un-checking "Enable Offline Mode," saving, edit again, re-check "Enable Offline Mode" and re-share with the group the map was participating in.

Maybe give that a try and see if it helps....also, make sure there are no copies of layers or layers originating from the same data source in your map. 

0 Kudos
ColinLawrence
Esri Regular Contributor

Hello,

Following up on Katherine's suggestions, generally this type of error is the result of something data specific. Having a copy of a layer in the Web Map is a common cause of this type of error. Please also check for special or reserved characters in the service name or fields. If you are still at a loss it could be worth turning off sync on the service and re-enabling it. Before doing this, ensure you have no existing replicas with outstanding data that needs to be synced. You could also try republishing. However, if it is data specific, these steps may not resolve your issue. 

Let me know if any of these suggestions help.

Regards,

Colin

0 Kudos
DeanaDeWire
New Contributor

I'm having this same problem and the "enable offline" trick above doesn't work.  I've tried deleting the feature layer and recreating it.  It still didn't work.  So I deleted the original geodatabase and recreated that, uploaded it to agol again and it won't even load into an agol map.  Any thoughts?  I'm following all same procedures that I typically follow to load data into agol and synch with collector... so i'm a bit confused. 

by Anonymous User
Not applicable

I'm also having the same exact issue!! 

0 Kudos