Offline Field Map Fails to Create -- Again

314
2
10-22-2021 06:13 AM
EL11
by
New Contributor II

I posted before about offline field maps failing to create. Well the problem is back and worse than ever.

1) Adding a layer to a map does not get added to the map offline. I tried syncing the offline and updating the offline area via the AGOL field maps site. The only way to get it to add is to create a brand new offline area which is not ideal with sharing with others.

2) I had some LIDAR tile layers that I added to the basemap. The AGOL field maps site creation of offline areas failed over and over again. For two days in a row, it would work after 6:30 PM but not before. The offline maps were 20 to 150 MB. When I tried to create things from the iPad, I could turn on the troubleshooting log. The only indication of something wrong was timeout errors on layers. 

Does anyone know if there have been issues getting offline areas during work hours and then working after work when the servers are less busy? Its been extremely frustrating to try and update maps for field work having the packages sometimes fail and sometimes work with no explanation of what happened differently.

2 Replies
Linde_Carmack
Occasional Contributor

From what I can tell if you add a new layer you must do a from-scratch new map area. The built in update and refresh functions are pretty limited. It seems like anything beyond just standard data editing can't actually be updated on an existing map area. Adding/removing layers, changing fields (adding/removing/changing domains), mass updating data (append or overwrite) and changing editing settings and templates all require a new map area. 

I can't speak to the LIDAR tile layer factor, but I have seen similar patterns with server load and success of map area creation. I package a new >700MB map area weekly and have definitely had more success doing it during lower server load times, although it's still doesn't always work on the first try. I agree that the lack of detailed failure/error information in the manage map areas tool is frustrating. 

 

0 Kudos
EL11
by
New Contributor II

Thanks for your information. Its good to know that you are seeing the same things. An error log for AGOL for anyone to download from the Field Maps application would be really useful for tracking down these errors.