Map Layer Failed to Load (3047 duplicate field) - Inspection Workflows and Join Features layer

1267
8
04-06-2022 10:58 AM
BrennanSmith1
New Contributor III

I am following the instructions in ESRI's Inspection Workflows YouTube video series.  I am using ArcGIS Pro 2.9 and Enterprise Portal 10.9.  My 'Join Features' layer is functioning correctly in the webmap, but will not load in Field Maps, with the following error:

Map: Hydrant Inspections Webmap
Layer: Recent_Hydrant_Inspections
Domain: ARCGIS_RUNTIME
Code: 3047
Description: Geodatabase duplicate field not allowed.

The issue is that both the feature layer (Hydrants) and related table (Inspections) contain a GlobalID field. When I perform a Join Features (so we can symbolize on most recent inspection), the resulting layer contains two GlobalID fields named 'globalid' and 'globalid_1649266887779'.  I can't find any way to remove one of these fields or resolve the issue.

How is it possible to view a 'Join Features' layer in Field Maps? Why did it work in Eric's demo but not in my environment?

 

0 Kudos
8 Replies
AndreasB
New Contributor

@BrennanSmith1 Did you already found a workaround for this issue? 

0 Kudos
BrennanSmith1
New Contributor III

Unfortunately no

0 Kudos
AndreasB
New Contributor

Bump

0 Kudos
Kristofer
New Contributor III

Hi Brennan Smith,

I had also the similar issue but now with the below given tricks we can resolve this issue.

First, Remove the Global ID from the Layer & add a new field in this layer with different name (not Global ID) and specify the data type as GUID.

When you perform the analysis join features, resulting layer will be only one global id field.

Regards,

Sunita

 

0 Kudos
BrennanSmith1
New Contributor III

Update: I worked with ESRI and this is now a known bug with our Enterprise (BUG-000148852).  Hopefully they patch it soon.

Sunita, thanks for the advice, but unfortunately we can't remove or rename globalID fields.  And because of how we will use the data layers, we need 'Supports applyEdits with GlobalIDs' to be True.

XV__
by
New Contributor

Hi @BrennanSmith1 , interested if this has ever been resolved. Facing the same bug.

0 Kudos
BrennanSmith1
New Contributor III

Unfortunately, the bug has not been addressed yet.  Its status is listed as 'Under Consideration'.  My workaround has been to add a "recent inspection date" field to my feature class, and run a script every night that updates this value.  It is far from ideal, and doesn't instantaneously update the labels and symbology, but it's something...

0 Kudos
StaceyCurry1
New Contributor II

Bump, I'm having the same issue! 

0 Kudos