Select to view content in your preferred language

Line Feature Layer Unavailable in Web Map & Field Maps

295
1
05-03-2022 11:02 PM
DustyJordan
Occasional Contributor

Hello,

I'm currently running into issues with a line feature layer in my web/field map. I've worked with plenty of point feature layers and have that pretty well figured out, but this is the first time I've tried creating a web map for use in Field Maps with both a point layer and a line layer. 

My feature layer publishes to AGOL just fine, contains both the point and line layers, but once I add it to a web map and save it, the line feature layer errors out and becomes inaccessible. This also becomes apparent in the Field Maps web app, when I open the map and try building the forms it throws an error saying the line feature layer is no longer accessible or doesn't exist. 

I'm wondering if there is some setting in the line feature layer that I have set in ArcGIS Pro which is incompatible with web/field maps? 

Thanks for any insights! 

0 Kudos
1 Reply
JonathanBowes
New Contributor III

Hi @DustyJordan. Did you manage to solve this issue from a while back because I have the same problem. It seems to be an issue with the form embedded in the webmap but I really don't want to have to delete the layer and rebuild it as it has a lot of code behind it. When I add the exact same layer into a new webmap and open it in Field Map the error disappears !!! But then I need to rebuild it.

Cheers for any pointers.

Jonathan

 

JonathanBowes_0-1694163250466.png

 

0 Kudos