Layers in Field Maps Not Editable

18885
26
Jump to solution
02-01-2021 09:04 AM
edatdcamm
New Contributor II

I have created a map in AGOL with editable layers. However, even though I checked the "Make Available in Field Maps App" under the map settings, it opens in the Field Maps app as "read-only", and there are no edit options available for the individual layers. How can I make the map editable? FYI, the feature layers within the maps are already showing as editable in AGOL.

26 Replies
swfbtucs
New Contributor III

Kevin,

I have just begun having the same problem Ed described, although I am not an enterprise admin and have no access to server logs or any of that. Perhaps your solution would work for me though on maps that I own, but I am having trouble following your solution prescription. You say save/resave and disable/reenable. To be clear, the save/resave refers to the Web Map, while the disable/reenable refers to the WFL, correct? So I would disable editing in the WFL, then open the Web Map and save it. Then close the Web Map, reenable editing in the WFL, then open the Web Map. What about the Field Map? Should I have deleted it? Disabled Offline Mode? What? There's more than two switches to think about here. 

 

KevinBurke
Esri Contributor

Thank you for sharing that news with me @edatdcamm! Glad to hear it's working now. 

0 Kudos
MelanieWawryk
Occasional Contributor III

Re-saving seems to work but to add to the discussion the same maps work in ArcCollector but don't work in Field Maps. Re-saving them allowed them to work in both.

0 Kudos
KevinBurke
Esri Contributor

@MelanieWawryk 

How many maps did you have this issue with that needed resaving?

Thanks

-Kevin

0 Kudos
MelanieWawryk
Occasional Contributor III

It happens all the time to me. From what I can tell if we add a field to the service or change domain values in the service it causes the plus sign to no longer appear in field maps. Now the first thing I do, if I have an issue, is create a copy and see if the copy works. Mostly that is enough to get it working again, if not, you have to check that your editing template matches your domain and that any definition queries match your editing template on the desktop side of things and that the fieldmaps setting all work too including making sure the include "no value" is unchecked on fields with domains. For me it all seemed to be trying to get everything to match within all environments before you can get the edit button to show up. Once it does any changes might disable it and creating a copy often restores it without doing anything else.  

0 Kudos
MelanieWawryk
Occasional Contributor III

To add to the thread, today the edit plus sign was missing in field maps but only for one out of three users, all on iPad all using the same application. Here is what was reported from the user with the issue after I copied the map in field maps to a new document:

Here’s what I found

  • I’ve re-logged in as myself a few times now and the “plus sign” still doesn’t work on the original app
  • I logged in as myself under the copy of the APP and “plus sign” shows up
  • I logged in using the forestry user account in the original app the “plus sign” doesn’t work on the original app
  • I logged in using the forestry user account  in the copy of the app and the “plus sign” shows up

Regardless of how I’m logged in the original app details indicate “Read Only”, while in the app copy details indicate “Editable”

Again this only seems to be affecting my iPAD, as everything works fine on my iPhone and no other users have reported an issue. I thought the issue might be because I’m logged in on 2 devices (iphone and ipad), but this doesn’t seem to be the case.

The only thing I did was copy the map using the copy button in field mapsand give the same group access but that was enough to fix the issue. The app worked fine the day before. Hope this helps solve what is going on in the backend. 

MelanieWawryk_0-1625790884062.png

 

0 Kudos
BrittanyBurson
Regular Contributor

Hi @KevinBurke , we are using Field Maps in Enterprise 10.8.1 with Map Viewer Beta.

We appear to be having this same issue, where the "Canvas is empty" and acts read-only if the map contains any Public layers hosted in ArcGIS Online. It shows no configuration or editable layers available.

Map contains AGOL Public layer:BrittanyBurson_0-1629325968692.png

Same map with AGOL Public layer removed:

BrittanyBurson_1-1629326119109.png

I tried a few different types of layers from AGOL and they all seem to cause the same problem. They are indeed visible, however, as layers in the Field Maps app without any issue -- it's just the configuration aspect that is stuck.

Thoughts?

0 Kudos