FieldMaps not opening offline basemap

1431
11
Jump to solution
07-07-2021 02:57 PM
MarcoPoetsch
Occasional Contributor II

Hi all,

I have created  a TPK basemap for offline usage and put this on my iPad in .../ Field Maps/basemaps/Aerial_Lod20.tpk

In the web map settings, as well as in the FieldMap settings, I said that the device should use this tile package for offline mapping.

MarcoPoetsch3_0-1625694755317.png

However, when I open the map in the FieldMap app on the iPad, the basemap is not turned on by default. I always need to change the basemap in the basemap widget.

Also: If i want to add/download an offline area, the basemap is not showing. I get the ESRI basemap instead.

Is there anything I do wrong?

0 Kudos
2 Solutions

Accepted Solutions
ColinLawrence
Esri Regular Contributor

Hi @MarcoPoetsch ,

I think you are on the right track but there are a few things to double check:

- Make sure you are placing the package in the root Field Maps folder (not directly into the basemaps folder). This shouldn't make a difference but the app is designed to look in the root folder and disseminate files on its own to the correct location. You may need to force close and restart the app for this to happen.

- Double check the name of the package. If its a tpk file keep in mind there are actually two possible extensions dependent on how you created it (.tpk vs .tpkx)

- The sideloaded basemap will not open by default for the Online version of the map however it is available for selection from the basemap tool.  You will only see this basemap when you attempt to take the map offline. I know you are having trouble with both workflows but I thought I would point that out. The app falls back to the default Web Map basemap if it cannot find the noted package. 

 

Can you try this workflow again and let me know if you still have issues? Thanks!

 

Regards,

Colin

View solution in original post

MarcoPoetsch
Occasional Contributor II

Well,... now it's working.

I don't now exactly why.:thinking_face:

What i did in addition:

  • I renamed the the TPK from Aerial_LoD20.tpk to just Aerial.tpk (so there is now number at the end)
  • I tried to open other maps
  • I reloaded the maps a few times

and then, it was here :)

 

Thanks @ColinLawrence , I think this is solved now ;)

View solution in original post

0 Kudos
11 Replies
ColinLawrence
Esri Regular Contributor

Hi @MarcoPoetsch ,

I think you are on the right track but there are a few things to double check:

- Make sure you are placing the package in the root Field Maps folder (not directly into the basemaps folder). This shouldn't make a difference but the app is designed to look in the root folder and disseminate files on its own to the correct location. You may need to force close and restart the app for this to happen.

- Double check the name of the package. If its a tpk file keep in mind there are actually two possible extensions dependent on how you created it (.tpk vs .tpkx)

- The sideloaded basemap will not open by default for the Online version of the map however it is available for selection from the basemap tool.  You will only see this basemap when you attempt to take the map offline. I know you are having trouble with both workflows but I thought I would point that out. The app falls back to the default Web Map basemap if it cannot find the noted package. 

 

Can you try this workflow again and let me know if you still have issues? Thanks!

 

Regards,

Colin

MarcoPoetsch
Occasional Contributor II

Thanks @ColinLawrence 

I tried your suggested workflow.

  • I put the TPK into the root folder. However, once  start FieldMaps the TPK is automatically transferred to the basemap folder.
  • I triple checked the naming and also renamed it.
  • Yes, I can find it in the selection. However, its not available by attempting to take the map offline.
0 Kudos
MarcoPoetsch
Occasional Contributor II

Well,... now it's working.

I don't now exactly why.:thinking_face:

What i did in addition:

  • I renamed the the TPK from Aerial_LoD20.tpk to just Aerial.tpk (so there is now number at the end)
  • I tried to open other maps
  • I reloaded the maps a few times

and then, it was here :)

 

Thanks @ColinLawrence , I think this is solved now ;)

0 Kudos
ColinLawrence
Esri Regular Contributor

That is peculiar. I at least have something to investigate perhaps around packages ending in numbers or with underscores. Glad it is working for you now though!

 

Colin

0 Kudos
AnthonyJones5
Occasional Contributor

Hi Colin,

I've recently come across this issue where FieldMaps would refuse to recognise the associated tile package when trying to create an offline area. I knew the tpk was in the right place as it would recognise it in the app when wanting to swap base maps. I've now found that if I set the offline tile package in the Field Maps web app then it doesn't work but if I set it in the map settings page then it seems to recognise the tpk file on the device. Is this something you are able to look into? Is there a bug in the Field Maps web app?

 

Also, on this topic, is there any reason we have to set a tile package in the map settings? In Collector Classic, when taking a map offline it would just allow you to select any side loaded tpk's from a list of those on the device. In some ways this was more convenient. Is there any chance that an enhancement could be introduced to allow Field Maps to read the tpk's on the device and allow the user to select one of those? This would allow surveyors to pick the base map they would prefer as the default.

 

Thanks

Anthony

0 Kudos
ColinLawrence
Esri Regular Contributor

@AnthonyJones5 Apologies for missing this one. 

is there any reason we have to set a tile package in the map settings? In Collector Classic, when taking a map offline it would just allow you to select any side loaded tpk's from a list of those on the device. In some ways this was more convenient

This is feedback we have heard from others since moving from Collector Classic and are considering ways to improve this. I believe there is an enhancement already logged with Support that you could request to be attached to. 

Setting a referenced .tpk at the Web Map level or the Field Maps Web App should both work. Is this still giving you issues? I can investigate. 

0 Kudos
AnthonyJones5
Occasional Contributor

Hi Colin, 

Thanks for the reply. That's great on the base map options. Do you know what the enhancement number is so I can keep an eye on it? 

On the issue I was experiencing with naming the base map in the Field Maps web app, I've just tested and it does look like this has been resolved now. 

Thanks

Anthony

0 Kudos
MattSchulz4
New Contributor

Hi Colin,

 

I have 44 TPK saved to the SD card, they were initially working with offline maps.  As in, when you clicked basemaps I had access to all of them.  Now they are not showing up.  They are in the proper location on the sd card.  Im perplexed because they were just working.  It is the same on 4 Samsung 12s. 

0 Kudos
ColinLawrence
Esri Regular Contributor

@MattSchulz4 Did anything change recently; for example did you recently update the Field Maps app or your OS version? Please confirm your current versions.

The folder storage location should not have changed recently. 

0 Kudos