Bring Back the Over zoom Basemap Capability

3141
16
05-02-2022 08:34 AM
Status: Open
LindseyStone
Occasional Contributor III

Our base maps via Field Maps use to zoom PAST the cached layers defined scales up until a few weeks ago.  I'm thinking some sort of update changed something.  I opened up the exact same map in Collector and we can still zoom in past the extent of defined scales.  This is new to Field Maps!

We need this capability back!!!  We are using a GPS with field maps and sometimes we need to zoom far in to see points that they GPS that are within 5 feet of each other.  Having the aerial basemap disappear on them is making it difficult for them to do their job.

Tags (3)
16 Comments
ChrisDunn1

Hi Lindsey,

The ability to zoom in beyond the maximum visible scale of a basemap was actually a bug (albeit a useful one for many people). Field Maps now honors the MaxScale setting in the json for the map so the basemap will disappear when you zoom in beyond that scale. The current easiest way to get around this and keep the basemap showing when you zoom in is to use https://ago-assistant.esri.com to change the MaxScale for the basemap to 0. This will keep the basemap visible no matter how far you zoom in.

I hope that helps.

Chris

JustinReynolds

@ChrisDunn1 

Please consider exposing this setting in the new map viewer's UI.  I'll post this as a new idea and link to this thread.

Linde_Carmack

 @ChrisDunn1 We really need this back, either as the default or exposing in the UI as suggested by @JustinReynolds. Right now this will require us to manually alter the JSON in AGO Assistant for every mobile map we create. Absolutely not sustainable. 

ChrisDunn1

We are currently working with the ArcGIS Online team to expose this setting in the map viewer UI, I will provide an update when we know more and/or when we have a timeline for it to be released.

LindseyStone

Your working on this for ArcGIS Online,  what about the people using Portal?

ChrisDunn1

@LindseyStone enhancements typically go through ArcGIS Online first and then are moved to Portal in subsequent releases, so it will come to portal as well.

For anyone experiencing this issue, I believe the following steps will give you an option to keep over zoom capabilities in your maps without using ago-assistant:

1. Create a map in pro with the basemap you want

2. Set the max scale to 0 (not none)

3. Save as a web map

4. Open the web map in the online Map Viewer

5. Move the basemap up to the layer section of the web map

6. Save it as a layer item

You will now be able to add that layer item to a map and move it to the basemap and it should honor the maxScale of 0 and allow you to over zoom. While this does require a few extra steps up front, it will at least create a re-useable basemap so you won't need to change the maxScale setting for every map you create.

I hope that helps.

Chris

DougMorgenthaler

Please see this knowledgebase article for details on this change.

JakeJacobsAVA

Agree with the frustration this change is causing. I am currently working with Esri support because the documented workarounds in the knowledge base article don't address sideloaded basemaps. The workaround is extremely awkward. I couldn't find any way to do it on an iOS device; I had to redeploy the entire tpk after making the change on a windows device (which is hours of file transfer) but the following does work:

1. Change the .tpk extension to .zip and unzip

2. For a tpk Go to servicedescriptions >> mapserver >> mapserver.json

2a. For a tpkx Go to root.json

3. Search for maxscale in Notepad ++ or something

4. Find the one that is not = 0 and change it to 0. 

5. Rezip using compression = 0 (store)

6. Rename the file extension

7. Redeploy tpk to device

Note that tthe Esri analyst I'm working with says there is currently no way in Pro to adjust this maxscale when you build the tpks or tpkxs - you will have to produce the package and then hack the file before deploying to the device.

JakeJacobsAVA

@ChrisDunn1 You mention exposing this in the map viewerUI for AGOL - but that won't help with sideloaded basemaps. We use tpks (see above) for our offline imagery. I think the option has to be exposed in Field Maps itself....

ECanGIS_Team

We are going through exactly same issue, trying to follow your steps but not sure how you mean by step 5? 

When i make changes, i dont see in the list of Basemap this newly created TPK, any clue/steps i have missed @JakeJacobsAVA ?