Select to view content in your preferred language

How to remove comma separator in Experience Builder table

07-13-2022 03:31 PM
Labels (1)
New Contributor II

Hello! I'd like to remove the thousands comma separator in the table I have in an experience:


I tried going to the visualization for the feature and unchecking the thousands separator. Also tried pulling the data from a web map where I did the same with no luck:




22 Replies
MVP Esteemed Contributor

What version of EB are you using? And is your datasource being referenced by the table directly, or is it a view? In older versions of EB, data source views would ignore field-level formatting options of the original data source.

- Josh Carlson
Kendall County GIS
0 Kudos
Esri Contributor

This is actually what we are implementing recently and the table will be able to honor the thousand separator (and other settings) soon.

0 Kudos
New Contributor II

Thanks @TianWen, looking forward to it

New Contributor

I still can't format the fields in the Table widget.

0 Kudos
MVP Regular Contributor

Any updates on this @TianWen ?

New Contributor II

@TianWen can you provide an update on this enhancement? Thousand seperators are still showing in enterprise Experience Builder 10.9.1 atleast. 

New Contributor

I'm utilizing Enterprise Builder in AGOL and we still are experiencing this issue. I tell you this because Enterprise releases generally follow AGOL and it has yet to have been implemented in AGOL. Maybe and ESRI rep can chime in but I have not found a resolution to this issue.

Take care.

Occasional Contributor

I'm still seeing this issue too.

New Contributor II

Have something similar...  with a bonus problem! 

When exporting a CSV on the export tool, we have some issues on the CSV. As some people are entering commas (,), well colums and lines are a total mess on Excel. 

Any ideas how to change the separator on ExBuilder? On the REST?


Thank you! for any help or work around!!!


0 Kudos