Select to view content in your preferred language

How to remove comma separator in Experience Builder table

5033
22
07-13-2022 03:31 PM
Labels (1)
CalebAnderson
New Contributor II

Hello! I'd like to remove the thousands comma separator in the table I have in an experience:

CalebAnderson_1-1657751309022.png

I tried going to the visualization for the feature and unchecking the thousands separator. Also tried pulling the data from a web map where I did the same with no luck:

CalebAnderson_2-1657751420201.png

 

 

22 Replies
jcarlson
MVP Esteemed Contributor

What version of EB are you using? And is your datasource being referenced by the table directly, or is it a view? In older versions of EB, data source views would ignore field-level formatting options of the original data source.

- Josh Carlson
Kendall County GIS
0 Kudos
TianWen
Esri Contributor

This is actually what we are implementing recently and the table will be able to honor the thousand separator (and other settings) soon.

0 Kudos
CalebAnderson
New Contributor II

Thanks @TianWen, looking forward to it

ShefaliVerma_afsc
New Contributor

I still can't format the fields in the Table widget.

0 Kudos
RobertAnderson3
MVP Regular Contributor

Any updates on this @TianWen ?

JoshTownsend
New Contributor II

@TianWen can you provide an update on this enhancement? Thousand seperators are still showing in enterprise Experience Builder 10.9.1 atleast. 

d-slet
by
New Contributor

I'm utilizing Enterprise Builder in AGOL and we still are experiencing this issue. I tell you this because Enterprise releases generally follow AGOL and it has yet to have been implemented in AGOL. Maybe and ESRI rep can chime in but I have not found a resolution to this issue.

Take care.

AW_Grove
Occasional Contributor

I'm still seeing this issue too.

CristianGraf
New Contributor II

Have something similar...  with a bonus problem! 

When exporting a CSV on the export tool, we have some issues on the CSV. As some people are entering commas (,), well colums and lines are a total mess on Excel. 

Any ideas how to change the separator on ExBuilder? On the REST?

 

Thank you! for any help or work around!!!

 

0 Kudos