Hide time in Table widget

3668
20
Jump to solution
02-16-2022 09:47 AM
Labels (1)
AmyRoust
Occasional Contributor III

I'm using the Table widget in Experience Builder (the online version, not developer edition). My date fields are displaying the time, and I'm wondering if there is a way to hide that? Time is irrelevant for this dataset - they just need to track the date.

screenshot.PNG

Tags (3)
1 Solution

Accepted Solutions
AmyRoust
Occasional Contributor III

I just checked the site that I had the issue on - the table is still displaying times and I don't see a button to suppress that or honor the SmartForms settings. As far as I know, this enhancement has not been implemented.

View solution in original post

20 Replies
ShengdiZhang
Esri Regular Contributor

Hi @AmyRoust ,

You can hide fields in the table widget settings.

ShengdiZhang_0-1645061872649.png

Uncheck unnecessary fields to hide them at runtime.

 

Regards,

Shengdi

0 Kudos
AmyRoust
Occasional Contributor III

@ShengdiZhang - that won't resolve my problem. I'm asking about hiding the time in a date/time field. I don't want to hide the entire field, but rather just the time. (See screenshot in original post.)

0 Kudos
ShengdiZhang
Esri Regular Contributor

@AmyRoust Sorry, I misunderstood your question.

If you just want to hide the time but keep the date, you can open your map in the new Map Viewer.

Select the layer, click on "Configure fields", and then select the field Last Invoice Date. Disable the "Show time" option, and you can see that only a date remains in the field.

ShengdiZhang_0-1645163026169.png

 

 

0 Kudos
AmyRoust
Occasional Contributor III

Thank you, @ShengdiZhang . Unfortunately, the table widget in Experience Builder does not honor that setting. I already have the time suppressed in the Map Viewer, but it still displays in the table widget.

Tiff
by
Occasional Contributor III

Hello @ShengdiZhang I wanted to follow up on this question. As @AmyRoust mentioned the Experience Builder table widget does not reflect the settings in Map Viewer. The time still shows but we would like to be able to hide it in the table.

KristinThorpe1
Occasional Contributor

Hi @AmyRoust! I am having the same exact problem. I've formatted the field to not show time everywhere I can think, but Experience Builder still shows the time. The only other place the time is visible is in the Content > Item Details > Data. The Table Widget must pull directly from the data source and ignore all formatting done in Map Viewer (even though the widget data is sourced from the map which is formatted correctly). 

Have you found a solution to your problem?

AmyRoust
Occasional Contributor III

Unfortunately, I have not found a solution. I prefer to use the Edit widget when I am updating that dataset because of that specific issue, but my end user manages the entire program and sometimes needs to update several sites at once. I submitted an ArcGIS Idea yesterday that included this request.

https://community.esri.com/t5/arcgis-experience-builder-ideas/tablet-widget-add-quot-update-quot-but...

0 Kudos
RobertAnderson3
MVP Regular Contributor

Did you find a way to get the Edit widget to not show the time? Or is it just easier to edit because of how it's broken up?

0 Kudos
MichaelDerevnin
New Contributor II

Any updates on that? I'm trying to migrate from WAB to Experience Builder... 

0 Kudos