Select to view content in your preferred language

GolbalId parameter cannot be accessed - Survey123 in Experience Builder

624
4
Jump to solution
11-05-2023 02:12 PM
Labels (1)
MelP
by
New Contributor II

Hi All,

I have created an experience using the survey widget. The user selects a record from the list widget which opens the existing survey record to edit. 

This works fine for users with admin roles however returns an error for Creator Data Editors.

MelP_0-1699221810879.png

I have followed trouble shooting here but am still unable to resolve. Has anyone else come across this issue?

The Survey, Feature layer and experience builder application are all set to Organization level sharing.

  

 

 

0 Kudos
1 Solution

Accepted Solutions
MelP
by
New Contributor II

Hi @gis_KIWI4 ,

I had the survey widget set up just as you have explained, checked survey layer had globalid (i knew this couldn't be the issue as editing the survey records worked fine for admin users).

I ended up creating a new survey (exactly the same as the the other) and it worked!!

No idea what the issue was but i suspect it may have had something to do with configuring permissions through the survey feature layer and re-publishing the survey a number of times which caused unexpected behavior. Noted here

MelP_0-1699416253484.png

Happy to say the issue is resolved!

Thanks,

Mel

 

View solution in original post

4 Replies
ZhifangWang
Esri Regular Contributor

Hi @MelP ,

The knowledge base article you referenced is the correct one to generally solve this error.

Can you please confirm that "Creator Data Editors" see the red error message for all survey records (including ones submitted by themselves) or only records that submitted by other users?

  1. If all records raise the same error, it means the feature layer (view) behind the survey is not shared appropriately.
  2. If only records submitted by others raise this error, it means detailed settings in the behind feature layer (view) is not correct.

In addition, can you please confirm if your survey was published from Survey123 Connect or the Survey123 website?

0 Kudos
MelP
by
New Contributor II

Hi @ZhifangWang ,

Thank you for your reply, i can confirm Creator Data Editors see the error message for all survey records. I am using the hosted feature layer (not a view - Do i need to be using a view?) and the settings are as in the screen shot below -

MelP_0-1699301948706.png

The Survey was published from the Survey123 website, share settings are as follows -

MelP_1-1699302660802.png

Any help on this would be much appreciated.

Thanks,

Mel

0 Kudos
gis_KIWI4
Occasional Contributor II

Hi @MelP 

I tried publishing a survey and using the widget within a ExB app. It seems to work for me. 
I think the issue might be in setting the up the survey123 Widget in ExB. 
Could you confirm if that mode is set to - "Edit an existing record" and the source layer is set to the survey123 layer? 

 

gis_KIWI4_5-1699408111928.png

 

 

In my example I have 2 datasources on the map.
When I select the one that is not the survey layer then I get the error suggesting GlobalID was not provided. 

gis_KIWI4_2-1699407834698.png

When I select a feature from the survey123 layer I can successfully edit the feature. 

gis_KIWI4_1-1699407767731.png

gis_KIWI4_4-1699408050725.png

 

If that's not it then you could try checking that the survey123 layer created has a GlobalID field in it. I don't see why it wouldn't but worth checking. 

Hope this helps 🙂

 

 

 

0 Kudos
MelP
by
New Contributor II

Hi @gis_KIWI4 ,

I had the survey widget set up just as you have explained, checked survey layer had globalid (i knew this couldn't be the issue as editing the survey records worked fine for admin users).

I ended up creating a new survey (exactly the same as the the other) and it worked!!

No idea what the issue was but i suspect it may have had something to do with configuring permissions through the survey feature layer and re-publishing the survey a number of times which caused unexpected behavior. Noted here

MelP_0-1699416253484.png

Happy to say the issue is resolved!

Thanks,

Mel