Experience Builder shipped with 10.8.1 not showing latest widgets

446
2
04-19-2021 07:45 AM
Pierredp
New Contributor

Good day,

We've recently upgraded to ArcGIS Enterprise 10.8.1 and I want to start using Experience Builder v1.0.0 (EB). I've watched the intro videos and decided to use one of the AGOL templates called "Presentation". I've clicked on the "create| button and it open EB but is stuck and don't load anything.

I've opened my browser's dev tools and saw that it is stuck because it is looking for the "card and "divider" widgets which I can't see in my widget list. I'm no developer but I did download EB v1.3x and copied the two missing widgets into my EB folders on the server and then the template loads but obviously with errors.

My question is when will the next non-dev version of EB be ready for 10.8.1 since I can't creat apps on AGOL due to our organisational policy? OR is there another way to get this working.

Any help will be appreciated.

Regards,

Pierre

2 Replies
Kara_Shindle
Occasional Contributor III

I ran into this issue with 3 of the other templates (including presentation) when I tried to open it in our portal.  10.8.1 as well.  Ended up using AGOL even though I didn't want to.  Interested in knowing this one.

TonghuiMing
Esri Contributor

Hi @Pierredp and @Kara_Shindle,

 

Thanks for bringing this up. Unfortunately, Enterprise 10.9 version has been released which includes the same issue, and the next one will probably be released in a few months. One workaround is to use basic templates such as Default to create your apps.

 

Typically, using new AGOL templates in old versions can cause code mismatch and some other errors. Thus, these new templates should not be present in the versions prior to the ones to which they were added, ideally. We will take a look at it.

 

Best,

Tonghui

 

 

0 Kudos