Exp. Builder Filters don't react to other elements on the same column.

457
4
Jump to solution
06-11-2021 10:34 AM
Labels (1)
JoseBarrios1
Occasional Contributor

The need: create several filters for a table and group filter by topic. 

The approach: create several individual filters within a column, keep the first filter open and set each of the other filter to "collapse filter details"

The problem: filters layout don't react to other filter widgets when one is opened (see pic)

Filters.jpg

 

 

Are there is any way to accomplish this? 

Thanks,

JB

 

0 Kudos
2 Solutions

Accepted Solutions
jcarlson
MVP Notable Contributor

How are your filters being arranged? I can have multiple filters in a single Column container with their heights set to Auto, and this seems to work just fine.

ExpandedExpanded

 

CollapsedCollapsed

 

- Josh Carlson
Kendall County GIS

View solution in original post

JoseBarrios1
Occasional Contributor

I figured it out! My problem was that the "Height" on the size settings for each filter need to be set to "Auto"

JB

 

View solution in original post

4 Replies
jcarlson
MVP Notable Contributor

How are your filters being arranged? I can have multiple filters in a single Column container with their heights set to Auto, and this seems to work just fine.

ExpandedExpanded

 

CollapsedCollapsed

 

- Josh Carlson
Kendall County GIS
JoseBarrios1
Occasional Contributor

Thanks Josh for a quick reply!. That was exactly my problem. It is working now, however I noticed that the filter collapse back every time I select one element within each filter. Do you know if there is a setting to fix that?

 

JB

0 Kudos
jcarlson
MVP Notable Contributor

That, I believe, is a bug with the "collapse automatically" setting turned on. I've never been able to turn that setting on without the filter repeatedly collapsing while I try to work with it.

- Josh Carlson
Kendall County GIS
JoseBarrios1
Occasional Contributor

I figured it out! My problem was that the "Height" on the size settings for each filter need to be set to "Auto"

JB