Select to view content in your preferred language

Unable to retrieve ArcGIS Server logs

3780
7
09-24-2020 08:56 AM
GercoFlonk
New Contributor II

Hi,

Somehow our ArcGIS Server doesn't return logs anymore. This is the case in the manager and on the REST endpoint (which is no surprise, as the manager seems to use this endpoint as well). Instead of logs the server is just infinitely 'pending':

Does anyone have an idea of what te problem could be? Tried rebooting the server but this didn't help.

0 Kudos
7 Replies
ChristoforosKatsaounis
Esri Contributor

Hi Gerco Flonk‌,

Couple of first questions,

1) What is the version and OS for your ArcGIS Server? 

2) Is there sufficient space (10 GB's min) on the ArcGIS Server machine's drives for both the install directory and ArcGIS Server config store and directories?  

-Christof

by Anonymous User
Not applicable

Hi Greco,

In addition to what Christof wrote above, I would make sure that the account running the ArcGIS Server service has access to the logs directory. From the web page you included in the screenshot, you should see a "Settings" icon in the upper right hand corner. Clicking this button will indicate the directory where the ArcGIS Server logs are stored. (By default, this is "C:\arcgisserver\logs\").

If you browse to that directory, do you see the logs being generated? Does the service account running ArcGIS Server have read/write permissions to that directory?

Thanks,

Calvin

0 Kudos
GercoFlonk
New Contributor II

Thanks for the replies.

Some info:

Server version: 10.7.1

There is 87GB of space left

Logs are being generated

We did resolve the issue this morning. The VPS on which the datastore was installed was not responding/operating correctly. After rebooting the VPS everything operated normally. The logs are now available in the manager and on the REST-endpoint.

Even though we fixed the issue, we're not quite sure what role the datastore has in correlation to the logging and why an unreachable datastore(server) would impact the retrieval of the logs. Maybe you could shine some light on this.

Anyway, thanks for the help!

FernandoTerceros
New Contributor

Hi I am having the same issue. I did re-started the ArcGIS Data Store and it worked for a few reports (3 times) then it stalled again.  

I am working with  ArcGIS Server version 10.6.x  There is well over 200GB of space left and the service account has local admin rights to the server as well as read/write to the log folders. 

0 Kudos
OmerBen-Asher
New Contributor III

Hi,

have you found a solution?

 

DebendraBiswas1
New Contributor III

Hello @GercoFlonk,

I am having the same issue on the hosting server, did you managed to find the root cause and the fix..?

WoodyGIS
New Contributor

Hi,

We've just come across the same issue and after 2 days of pulling my hair out have found a solution that worked for us. For context, our solution is a highly available Enterprise with the Portal, Server and Datastores on the same machine.

In short, a relational datastore removed itself from one of the machines and caused the primary datastore to save the backups back on the local c drive, not the designated shared folder. This slowly filled the c drive up and caused the primary datastore to enter read-only mode, which we subsequently cleared and set back to read/write with no joy.

The fix was as follows:

  1. Remove the standby relational and tile cache machines from the site
  2. Stop the standby datastore service
  3. Rename the c:\arcgisdatastore folder to c:\arcgisdatastore_old
  4. Start the standby datastore service
  5. Reconfigure new relation and tile cache stores using the datastore configuration wizard
  6. Make the standby datastores the primary
  7. Repeat steps 1 - 5 for the other datastore machine (old primary, new standby)

Some further details on some of these steps can be found here: Error: ArcGIS Data Store has detected a replication failure (esri.com)

We also noticed that the missing datastore would show up when validating in Server Admin or using the describe datastore tool, but not when accessing the datastore configuration https://machine.fqdn:2443/arcgis/datastore

0 Kudos