TableToExcel Geoprocessing service not working when the service layer source from SDE (MS SQL 2016)

270
2
08-22-2017 11:52 PM
Musa_SerkanArslan
New Contributor III

I am having a problem with TableToExcel geoprocessing tool. My data in SDE database which works on MSSQL 2016. Script works fine in ArcMap what after puplish it as GPService it gives below error. 

Error executing tool. TableToExcel_log Job ID: jdfcc06e8e5564b39bc507928ae9aeb28 : Traceback (most recent call last): File "E:\arcgisserver\directories\arcgissystem\arcgisinput\Geoprocessing\TableToExcel_log.GPServer\extracted\v101\geoprocessing\TableToExcel_msa.py", line 241, in arcpy.GetParameter(3)) File "E:\arcgisserver\directories\arcgissystem\arcgisinput\Geoprocessing\TableToExcel_log.GPServer\extracted\v101\geoprocessing\TableToExcel_msa.py", line 141, in table_to_excel fields = get_field_defs(in_table, use_domain_desc) File "E:\arcgisserver\directories\arcgissystem\arcgisinput\Geoprocessing\TableToExcel_log.GPServer\extracted\v101\geoprocessing\TableToExcel_msa.py", line 98, in get_field_defs if arcpy.Describe(ws).dataType == 'FeatureDataset': File "c:\program files\arcgis\server\arcpy\arcpy\__init__.py", line 1253, in Describe return gp.describe(value) File "c:\program files\arcgis\server\arcpy\arcpy\geoprocessing\_base.py", line 376, in describe self._gp.Describe(*gp_fixargs(args, True))) IOError: "\gisdb.GDB.Services" does not exist Failed to execute (TableToExcel-log). Failed to execute (TableToExcel_log).

I tested the same tool with with other layers which the data source is filegeodatabase and it works fine. 

Is there any one can guide me to about problem.

Also the tool is not working when subtype and domain option true and if there are some empty value in subtype field. This problem is solved for me when values are entered.

Thanks...

0 Kudos
2 Replies
shan_sarkar
Regular Contributor

Does the issue replicate with subtypes and domains when used in file geodatabase?


~Shan
0 Kudos
Musa_SerkanArslan
New Contributor III

My data in SDE (on MS SQL) and many of feature classes including domain values, and only One feature class include also subtype. GP Service is not working for all layers either with subtype or without. 

But the tool is working for layers which sources are from file geodatabase.  

Second problem is; if featureclass has subtype field and that field includes empty value, on this time it gives another error even layer from file geodatabase. 

0 Kudos