Publish from ArcMap to a server configured to use SAML

1549
10
03-02-2018 07:39 AM
OmerPiperdi
New Contributor II

I have installed ArcGIS Enterprise Builder 10.5.1 which is configured to authenticate with SAML/Shib. and both portal and server are federated to use single sign-on. When I tried to publish a service from ArcMap, is there a special option to login if the server is configured to use SAML? I am getting error message as in attached image.

Thanks,

Omer

0 Kudos
10 Replies
RandallWilliams
Esri Regular Contributor

Before you go down another route, I'd delete and recreate the connection to the GIS Server in Catalog. That sometimes helps to fix issues like this. There isn't another dialog to connect directly to the GIS Server that I'm aware of. There's the PORTAL login when publishing hosted feature services, but not for publishing 'classic' services.

0 Kudos
OmerPiperdi
New Contributor II

It connects just fine, if I use a local account. I selected the Sign In Options to either login with SAML or local account.

0 Kudos
RandallWilliams
Esri Regular Contributor

OK, that makes sense.

Does this ring true:

When making the publisher or administrator connection within ArcCatalog or ArcMap, supply the ArcGIS for Server URL, but leave the username and password field blank, select Finish and a Window pop-up with the option to sign in using the (Security Assertation Markup Language) SAML account.

OmerPiperdi
New Contributor II

I tried to leave it blank and uncheck the "Save Username/Password' box but now I get this message.

0 Kudos
HaydnDyer1
New Contributor

Omer,  

Did you find a resolution to this issue?  I have come across the same issue with v10.6...

Note:  I have not used Enterprise Builder but have SAML setup for a Federated Portal and I receive the same error when connecting to ArcGIS server via  the 6080 and 6443 URLs.  I have also tried via the Web Adaptor URL and get similar errors if I capture the traffic.

Thanks,

Haydn

0 Kudos
OmerPiperdi
New Contributor II

I am still not able to login from 'Publish' menu in ArcMap but there is

a work around using ArcGIS Administrator and configure the Portal

connection there.. when I use this option, it prompt me to login via

SAML, looks like that keep the session alive and I can use this

connection in ArcMap to publish. Here is more info. about this

configuration.

Connected to portal as given in the

link http://enterprise.arcgis.com/en/portal/latest/administer/windows/use-with-desktop.htm

Signed into Portal for ArcGIS from ArcMap by navigating to File > sign

in

(http://desktop.arcgis.com/en/arcmap/10.5/tools/server-toolbox/sign-in-to-portal.htm)

HTH,

Omer

0 Kudos
HaydnDyer1
New Contributor

Thanks Omer, 

This resolved the issue for me.   In v10.6, once I connected to the federated portal via ArcGIS Administrator I could publish to ArcGIS Server and also make administrative & publisher connections to the server.

Esri just need to update this documentation http://enterprise.arcgis.com/en/server/latest/administer/windows/about-connecting-to-arcgis-server-i... to include this information...

Haydn

0 Kudos
SzymonPiskula1
New Contributor III
0 Kudos
Sanderten_Arve
Esri Contributor
from: https://enterprise.arcgis.com/en/server/latest/install/windows/making-a-user-connection-to-arcgis-se... (mentioned from version 10.5 and above)
Note:

If the ArcGIS Server site you're connecting to is federated with a portal, provide portal credentials. If your portal uses SAML authentication, you cannot connect directly to the federated server from ArcMap.

0 Kudos