Problems when adding or updating features from GEP v10.5

12-23-2016 09:59 AM
New Contributor II

I publish a feature service from ArcMap 10.3 (I enable feature access) to ArcGIS Server 10.5 Licensed Role: GIS Server Standard, GeoEvent Server. But when GEP update or add a feature I get :Requested operation is not supported by this service. 

I also try using apply edits or add feature form web, but same result.

Somebody can help me? 

Thanks in advance! 


Tags (1)
0 Kudos
1 Reply
New Contributor II

@Mauricio_Arroqui I guess you probably have solved the issue. For the people who also visit this page. Check the following things:

1. Go to the arcgis/Manager. Select the folder -> service -> capabilities and click on the feature acces. Make sure the Create,Query and Update boxes are checked.

2. Check if the correct datastore is connected (this was in my case the issue). To check this I uploaded data through ArcGIS Pro and it was available in my database but not queryable in my feature server. So check your added datastores from: site -> data stores.

If it is missing. Create a DB connection file in arcgis PRo (save user and password in the process). Klick on database and then add database.

Republish your service and it works!

0 Kudos