PrintingTools GP Service missing tasks after upgrade to ArcGIS Server 10.6

2223
11
Jump to solution
01-26-2018 02:19 PM
JoelBrown
New Contributor II

I just upgraded from ArcGIS Server 10.2 to 10.6.  After the upgrade the default Utilities/PrintingTools GP Service does not have any tasks listed (see attached screen shot).  I believe this service should have a "Export Web Map Task" and a "Get Layout Templates Info Task."   Does anyone have any idea on what happened and/or how i can resolve this issue?  Thanks.

 

1 Solution

Accepted Solutions
TanuHoque
Esri Regular Contributor

let's see whether this helps:

- delete the service using Manager/Admin side

- create a new one following instructions from How To: Restore the default PrintingTools service in ArcGIS Server Manager  using the json from 10.6 section

View solution in original post

11 Replies
TanuHoque
Esri Regular Contributor

Joel,

Could you pls contact Esri Support and have someone take a look at this? It is hard to say what is going on without looking at the server/service settings etc.

thanks.

0 Kudos
JoelBrown
New Contributor II

Thanks for the quick response.  I'll try and get a support ticket rolling but in the mean time i would like to troubleshoot here if possible.  Please let me know what server/service settings you are interested in.  I believe the printing tools GP service is the default service that came installed out of the box when we originally installed AGS 10.2. Thanks.

0 Kudos
JoelBrown
New Contributor II

Quick update.  I just tried creating a new print service using the instructions in the link below.  The new print service was also created with no tasks. 

How To: Restore the default PrintingTools service in ArcGIS Server Manager 

0 Kudos
MatthewDowning2
New Contributor III

Hi Joel - did you ever resolve this issue? I also recently updated to 10.6 and am experiencing the same issue.

0 Kudos
JoelBrown
New Contributor II

No.  I have not resolved the issue.  Hoping someone from ESRI can chime in with something beyond "call support." 

0 Kudos
TanuHoque
Esri Regular Contributor

let's see whether this helps:

- delete the service using Manager/Admin side

- create a new one following instructions from How To: Restore the default PrintingTools service in ArcGIS Server Manager  using the json from 10.6 section

Joshua-Young
Occasional Contributor III

Thank you. These steps fixed the issue for me. The default print service now has its items under Tasks again. We upgraded from 10.5.1 to 10.6 and the Tasks were missing.

0 Kudos
JoelBrown
New Contributor II

Thank you.  I actually linked to that document in an earlier comment but i see that you have now added instructions specifically for AGS 10.6.  The updated instructions do indeed work.  

0 Kudos
by Anonymous User
Not applicable

This happened to me upgrading from 10.5.1 to 10.6.1 and these steps worked! Thank you!

0 Kudos