Is it possible install ArcGIS for Server on Linux without graphic enviroment?

2169
4
05-11-2016 09:24 AM
NorwillGutierrez
New Contributor

I'm newbie on ArcGIS, recently (yesterday) install ArcGIS for Server 10.2.2 on Suse Enterprise 11 SP4 everithings go ok until i try to start the server.

When i try to start the server from installdirectory ./startserver.sh return this:

ERROR: Unable to start Xvfb on any port in the range 6600 - 6619.

This installation is on azure without graphic enviroment (initially) then i install the graphical enviroment and still present this error.

Any idea to solve this?

Thanks in advance.

0 Kudos
4 Replies
AnthonyKobah
Occasional Contributor

Hi Norwill,

Run the Server Diagnostic Tool to help troubleshoot the issue. See link

ArcGIS Help (10.2, 10.2.1, and 10.2.2)

0 Kudos
NorwillGutierrez
New Contributor

Hi Anthony thanks for you reply, when i run the diagnostic show this:

<PROMPT_CHECK_ROOT_INSTALLER>                             <STATUS_PASSED>
<PROMPT_CHECK_OS_ARCH>                                    <STATUS_PASSED>
<PROMPT_CHECK_OS_VERSION>                                 <STATUS_PASSED>
<PROMPT_CHECK_HOST_NAME_BAD_CHARS>                        <STATUS_PASSED>
<PROMPT_CHECK_INSTALLED_PACKAGES>                         <STATUS_PASSED>
<PROMPT_CHECK_SYSTEM_LIMITS>                              <STATUS_PASSED>
<PROMPT_CHECK_OS_PATCHES>                                 <STATUS_NA>
<PROMPT_CHECK_SERVER_PORT>                                <STATUS_PASSED>
<PROMPT_CHECK_HTTPS_PORT>                                 <STATUS_PASSED>
<PROMPT_CHECK_XVFB_PORTS>                                 <STATUS_PASSED>
<PROMPT_CHECK_HOST_NAME_ENTRIES>                          <STATUS_PASSED>
<PROMPT_CHECK_CORE_SERVICES>                              <STATUS_WARNING>

When i run the installation all the items marks as passed, right now i have the url working here:

ArcGIS

I start manually tomcat.

I need to start the server anyway using the xfvb ?

Thanks

0 Kudos
AnthonyKobah
Occasional Contributor

Norwill Gutierrez

So, it appears the XVFB server is good. Check if the needed port is opened. One port within this range 6600-6619 is needed by ArcGIS Server.

Run this command in terminal. "netstat -lntu". You might need to open the port for it to work.

NorwillGutierrez
New Contributor

Thanks  again Anthony you give me a great idea.

with the command netstat -lntu i see the ports listening and change the por for xvfb now is running all ok.

The next step is configure web adaptor, is installed and copy the file arcgis.war to bin tomcat folder but i can't acces to the url.

Any idea?

0 Kudos