Intermittent print issues

1121
3
01-10-2017 09:33 AM
TracySchloss
Frequent Contributor

Has anyone else ever had just intermittent print issues?  Using either the out of the box printing or a custom print template, we will randomly have tasks to generate output throw connection errors with the ESRI basemaps.    We think it is getting stopped by some security configuration, but the sheer randomness of it has us completely baffled.

We contacted ESRI technical support, but weren't able to get very far in the conversation.  The fact that it works part of the time, and other times fails makes this extremely hard to troubleshoot.  It will fail 4-5 times in a row, then work flawlessly for an hour before deciding to fail again.

We have our printing set up to be synchronous, because it doesn't seem like a long enough task to require the setting of asynchronous.  

I have a sample bit of code that doesn't have any ESRI basemap on it, and I have yet to see it fail.  Unfortunately our users expect to see the same map on their printout that they see on the screen.  

Tags (1)
0 Kudos
3 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

I converted this thread to a question vs a discussion....you will have better luck getting views and comments.

Are you using and having issues with printing from a web app, and if so, what are you using (Javascript, ArcGIS Online, Web AppBuilder thru ArcGIS Online or Portal or Developer Edition)?  What version of ArcGIS Server and/or the dev environment?

I was going to mention to use synchronous (vs async) since that was a solution for an issue I was having, but you are already doing that.

Are you mixing secure and unsecured services?  I have some notes and tips that I wrote up a while back....not sure if they still all work or not (mine has worked for a while, so haven't revisited).

0 Kudos
TracySchloss
Frequent Contributor

I am using the JSAPI, version 3.14, I think.  That doesn't seem to make a bit of difference, though.  The AGS is version 10.3.1.  It was doing the same thing in 10.2.2.  I'm not prepared to upgrade any further.  We have to maintain our versions across the enterprise.  I am not convinced at all it's anything to do with AGS itself and more with a setting/permission we need to open up in our security.  It's locked down pretty tight, but the network and cyber

security groups are willing to work with us to open it up a bit more, if only we can figure out what to change.  I will tell you these are not new applications and all worked until several months ago when then starting implementing new firewall/security settings.  We've been fighting it every since, and hoped at least upgrading to 10.3.1 would help. 

What about the security patches for 10.3.1?  Might they help?  Our system staff is always leery of stacking change on top of change when they're trying to troubleshoot. 

All our local services are called via https, but it's hard to control how the ESRI hosted basemaps are called, since they are referenced through the JSAPI basemap gallery widget.  The error doesn't seem to be related to mixed content.  When the printing fails, this is the sort of message I see in the AGS logs.  They all say the call is https.  It failed 3-4 times when I first tried to print this AM, then proceeded to work for the next 5 or 6 tries.  The behavior is the same in IE or Chrome.  We've been looking at SSL, but this is way outside my area of expertise, so I can't tell you what all has been attempted.  We see the same sort of problem no matter whether we are using out of the box printing or a custom template.

A connection with the server could not be established (WinINet Error while using HTTPS security, 12029), URL = https://services.arcgisonline.com/ArcGIS/rest/services/World_Street_Map/MapServer?f=json

Source:  PrintTemplate/ExportWebMap.GPServer

0 Kudos
GISTeam2
New Contributor II

Hi Tracy and Rebecca,

I know this thread is a few years old now, but did you resolve your issues Tracy? We also are experiencing intermittent print issues. We are just using regular Web App Builder in ArcGIS Online and printing a combination of  secure (feature layers) and unsecure (base maps) services. Sometimes printing works as expected, sometimes we get ArcGIS Server log errors stating 'Unable to connect to map server at https://utility.arcgis.com......', which is always related to the secure service layer we are trying to print.