Failed to execute (ManageMapServerCacheTiles)

2635
4
07-18-2016 01:17 PM
DaveTenney
Regular Contributor

has anyone else experienced any errors such as the following:

ExecuteError: Failed to cache extent: -####.#### ####.####-####.#### ####.#### at scale 1128.4971760000001 The index was either too large or too small.

Failed to execute (ManageMapServerCacheTiles)

running a python script in 10.2.2 to updated tiles of cached services based on any edits, deletes, etc. once the scripts starts to wait for this process to run, the above error is raised.

thanks in advance!

Dave

0 Kudos
4 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

yes, it has been a common (that is, I had it that error .   ) issue/question.

The index was either too large or too small -  Map Cache Error

I would read thru this thread, then start at the bottom, and work up. some parts are for 10.1, not 10.2.2.

Additional, possibly related threads...

Failed to cache extent. Index was either too large or too small

Manage Map Cache Tile: Errors at 10.2.2

ArcGIS Server 10.3 failed to cache

See if any of those things help.

DaveTenney
Regular Contributor

update...

    the process finally ran completely!

we found an issue with one of the bundles and deleted it, the first 3 attempts arcgis would not rebuild the deleted bundle. for some reason on the 4th attempt it was rebuilt completely. this is one thing that is driving me nuts...

   we try and trouble shoot things for possible future events and the out of nowhere the process works. were running into this with almost everything...oh its not working, 4-5 attempts later it works, back to oh its not working and now it is, repeat as needed.

we do have another service that is throwing a similar error. this service as orthos in and we got hundreds or coordinates (many of which are duplicated) currently trouble shooting that issue.

thanks again for the links and help.

dave

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

might be just timing our on trying to reach the data sources for caching.  just a thought. 

I know I have never had luck with the "replacing" of cache tiles and usually manually delete them, then refresh the status gdb and recreate them.  sometimes I have just renamed the folder, created the levels that were a problem (letting it recreate the folder) and then merge the two together.    Sound like it was "semi" resolved, but troubleshooting this is not easy.

0 Kudos
DaveTenney
Regular Contributor

so a new issue....

ExecuteError: ERROR 999999: Error executing function.

Bad syntax in request.

Failed to execute (ManageMapServerCacheTiles).

  we now get this error out of no where!

one thing we noticed is we decided to run the same script in two different environments Envo1 = 10.2.2 & Envo2 = 10.3.1

  Envo1 = error message seen above

  Envo2 = currently running, has gotten further than Envo1

is it possible that is just an instability issue with 10.2.2? or have other run into this same issue? We cannot find anything in the Logs to clue us in as to what is going on that raises the error, even at the "debug" level of logging provided zero info.

thanks

Dave

0 Kudos