Export Web Map Task Generates an Internal URL. No Access to Public.

04-27-2017 04:39 PM
Occasional Contributor

I have an Export Web Map Task hosted on my organizations GIS Server (Technically it's published to the test server), and it works great, BUT the output file that is created (JPEG, PDF, etc) is only accessible from behind our firewall.  Has anybody experienced this issue before?  Is the solution as simple as modifying the job directory?

To reiterate, I am able to call on the REST URL of my Export Web Map GP task within a web map, and a link/URL to the output file is generated.  The URL to the output file looks something like this: "

This URL is only accessible from behind our firewall though.  If I'm not VPN'd in to our network, or connected directly, I cannot access the resulting map file.  This REALLY limits who can use my print task.

I believe we use something like WebAdapter to allow public access to our services hosted on our server.  Just for fun, I replaced the IP address in the URL above with the domain that is used for public access, and sure enough the file became accessible from outside of our firewall.

So this URL worked outside of our firewall:


I think I need my output file URL to be built using our public facing domain (https://test-fortress.wa.gov/agr/gis/), rather than the internal address of our server.  Any Ideas?

Any help is appreciated!


0 Kudos
1 Reply
Esri Notable Contributor

What URL did you use to access the web adaptor when registering it with your Server?  Have you tried to set a web context URL that points to https://test-fortress.wa.gov/agr/gis?  I've never tried to set with with two "contexts", (agr and gi...

0 Kudos