Error DBMS table not found [UN_6_Associations] When Re-Starting Utility Network Service

1507
6
09-03-2021 06:56 AM
Billy
by
Occasional Contributor II

Hi, 

This is the configuration of our system:

ArcGIS Enterprise 10.8.1 (Server, Portal, Web-Adaptor, Data Store, SQL; all running on independent VMs)

SQL Server 2017

ArcGIS Pro 2.8

Utility Network Version 4

Below you can see the errors that I'm getting when I try to start a service associated with a Utility Network model. The table that is being reference in the error is part of the Utility Network model and is present in the database when I look in SQL Server, also when I connect directly to the database in ArcGIS Pro and consume it on a map I can see all the data and the associations that are in table [UN_6_Associations]. Therefore, the database has the table and the data is there. 

The problem began with 2 services that were already published and today I publish a new service ("Project_Service") from the same database, but I'm still getting the same error. 

Before the problem started I was trying to delete a feature class from the database associated with this services, this feature is not part of the utility network schema. I right click the feature class and clicked the delete option, but I got this error  (see last image below) "Cannot get exclusive schema lock". Then I went to server manager an stopped the 2 services associated with the database. Tried to delete the feature class again wit the same result. 

I decided to call ESRI support, the analyst guided me into checking the locks on the database using Pro (Administration\Locks) and then try to disconnect the all the users; but the option was grayed-out. I'm the only one using this database and service in the company. I'm the only one with ArcGIS Pro access in the company. Then the analyst wanted me to check SQL Server. He sent me some queries to run and check the users connected to the database, but they returned empty. Finally he wanted me to check the rights of the database user in the security section of the database and we change one parameter there. After going back to Pro and getting the same result when trying to delete the feature class, the analyst said the he needed more time to look into the problem. That's when I tried to re-start the services and got the "DBMS table not found" error. 

Billy_0-1630677260788.png

Billy_1-1630677290411.png

 

6 Replies
MichaelGinzburg
Occasional Contributor II
Did you try to stop ArcGIS server service before deleting the feature class? It may lock the DB. Not a service in the Server Manager - the ArcGIS Server Windows service.
0 Kudos
Billy
by
Occasional Contributor II

Hi Michael,

I stopped the service in Server Manager only. I didn't do anything on the machine running ArcGIS Server.

0 Kudos
LoganSuhr_PSE
New Contributor III

Any new developments here?  I'm having the exact same issue.  I cannot delete feature classes or disable network topology in my UN database.  And I can't restart the service.  I get the same notification.

ChaseYoung323209
New Contributor

Any update on this? I am having the same issue.

0 Kudos
JCGuarneri
Occasional Contributor II

Were you able to resolve this? We're having this issue as well.

0 Kudos
SimonAlfordEsriAU
Esri Contributor

Check that the 'database utility network owner' is not a database administrator (or the geodatabase administrator). A client with an enterprise geodatabase deployed on SQL Server discovered that the 'database utility network owner' was a member of the sysadmin server role.

As per the following document this "user must have database privileges to create content and cannot be an OS-authenticated user, a database administrator, or the geodatabase administrator account."

Create a utility networkhttps://pro.arcgis.com/en/pro-app/latest/help/data/utility-network/create-a-utility-network.htm

0 Kudos