Editor Tracking displays ESRI Anonymous

886
5
Jump to solution
08-07-2023 03:24 PM
austinbraget29
New Contributor II

Hello,

When collecting data using Field Maps, the created user and last edited user fields display Esri Anonymous instead of the person's name. We are using ArcGIS Enterprise 10.9 that is federated with an ArcGIS Server 10.9. The feature class is a point that is in an enterprise geodatabase and in a feature dataset. The point feature class has editor tracking enabled. 

When collecting data with Field Maps, they are required to sign in using their own organization account. Even when I try doing the same workflow as the field crews, my submissions show up as Esri Anonymous. If I move the point in ArcGIS Pro, then it will display the last edited user correctly but it seems the intial submission is having issues.

0 Kudos
1 Solution

Accepted Solutions
austinbraget29
New Contributor II

The solution to this problem was setting the sharing level to Organization on the feature/map service in portal.

It was set to Public but once it was set to Organization then the created by field would correctly populate.

Thank you ESRI support and David for the help.

View solution in original post

5 Replies
David_McRitchie
Esri Contributor

Hey can we confirm that this is just within ArcGIS Enterprise or is any of the data being moved and used within ArcGIS Online?

I came across this technical article which may provide some assistance if ArcGIS Online is also in use.

 

Can we also confirm if SSO is being used, or if this is using built-in named user accounts?

 

Many thanks,

David

Esri UK -Technical Support Analyst
0 Kudos
austinbraget29
New Contributor II

Hello David,

This is just within ArcGIS Enterprise, it does not get used in ArcGIS Online. SSO is being used.

0 Kudos
David_McRitchie
Esri Contributor

Hey Austin,

I am not quite certain in this case. Do you get the same behavior in other apps such as Survey123 or when making edits in the Map Viewer? If not then it could be an issue with anonymous access, or with using Offline maps.

 

Many thanks,

David

Esri UK -Technical Support Analyst
0 Kudos
austinbraget29
New Contributor II

Hello David,

If I make edits in the Map viewer (On my computer), then it does show my name. If I login to my enterprise site (On my phone using cellular data), then it also shows my name. So it only appears to be an issue when  using Field Maps on a phone. They are using an external GPS unit connected to their phones. Our field crews do not use offline maps but they are using cellular data not WiFi.

I did come across this help doc detailing if no ArcGIS Server credential is provided for the service then edits are considered to be from a nonauthenticated user and will record ESRI_Anonymous. But why would that only happen when accessing the data in field maps? Is there a setting in ArcGIS Server Manager that needs to be set?

0 Kudos
austinbraget29
New Contributor II

The solution to this problem was setting the sharing level to Organization on the feature/map service in portal.

It was set to Public but once it was set to Organization then the created by field would correctly populate.

Thank you ESRI support and David for the help.