Cannot publish map service with new tile cache

593
2
02-10-2022 09:20 AM
MKF62
by
Occasional Contributor III

I'm trying to publish a map service and have it create a new tile cache at publishing. I am connected to my server with an administrator connection. In the map service properties I choose:

Layer Drawing: Using tiles from new cache
Tiling scheme: ArcGIS Online/Bing Maps/Google Maps
I select my levels of detail, img format of PNG
I have "Cache automatically on the server" turned on. I have checked that the cache directory is correctly mapped.
For extent I have used "Area of Interest" and chosen the feature layer that I want to create tiles for.

The map service seems to publish empty, and in the arcgiscache folder, I see a folder of the name of the service I published, but there are no tiles in it. The tool results say this in the last few messages

Validating service definition
Creating the service.
Succeeded.
Publishing map service succeeded.
Publishing tool succeeded.
Sucessfully completed publishing call
Post-processing on the server
Initializing caching process on the server
Error: Problem submitting tile caching job

Google searches suggest restarting the CachingControllers and CachingTools services which I have done multiple times over. I have also viewed the logs in Debug mode and it seems like something is being submitted with empty parameters:

Error executing tool. Manage Map Cache Tiles Job ID: <ID name>
ERROR 000735: Input Map Service or Image Service URL: Value is required
ERROR 000735: Scales: Value is required
ERROR 000735: Number of caching services instances: Value is required
ERROR 000800: The value is not a member of RECREATE_EMPTY_TILES | RECREATE_ALL_TILES | DELETE_TILES | COMPLETE_JOB | FIX_JOB | RESUME_JOB

Source: System/CachingControllers.GPServer

I have ensured that the CachingControllers service has enough instances available. 

Am I not understanding what "Layer Drawing > Using tiles from new cache" does? When hovering over it, the explanation given is "Draw from pre-cached images generated at scale levels you define." Does the "pre-cached" mean it's not going to create a cache for you, but rather you already have one sitting on the server that it will go look for? It seems like the next option would be more appropriate if that was the case ("Using an existing cache"). Based on the above error message, the CachingControllers is calling a tool that only works with existing map caches which would be why I'm getting the empty parameters.

I have tried saving the service definition and uploading it and it works successfully with no error messages, but the map service publishes empty (the thumbnail in server manager shows the map I want though) and no tiles are created in the arcgiscache > service name > map name > _alllayers folder. When I go to my rest/services page, I see the map service there and I see a list of tiles at each scale I want, but if I click "start tile" on any of them, I get a 404, not found error:

Screenshot 2022-02-10 121041.png


I hope someone has some insight because I'm stuck. If the solution is publishing a tile cache to the server before trying to publish the service, what tool would get me started?

 

Tags (1)
0 Kudos
2 Replies
NorthernGeo
New Contributor

We are experiencing a similar issue - have you discovered why? We checked firewall, malware, reinstalled the caching tools - all to no avail. Nothing is written into the "_alllayers" folder. Our next step is to repair our server. 

0 Kudos
MKF62
by
Occasional Contributor III

Nope, I never was able to solve this. Any chance you’re using a mixture of local and domain accounts for using your ArcGIS Pro installation and ArcGIS Enterprise services? I have since left the position where I had this problem, but I worked remotely, had to use a local account on my computer and go through a VPN where I did stuff in Pro. I then tried to publish services where our server was run by a domain account and I think this caused a lot of weird issues for me. ESRI tech support claimed my mixed account types was the problem when I found I was unable to register folders, so I wonder if my mixture of account types played into this problem too. 

If your publishing attempt is failing the exact same way mine was (the debug log says the same as what I denoted), after the job fails, maybe try running the Manage Map Server Cache Tiles tool directly and see what happens? That’s the tool the debug log says is failing during publishing and it is a tool that can be run by itself in Pro. I can’t remember if I tried that.

0 Kudos