Can't publish service: "Probable cause: The file is inaccessible to Server."

07-29-2015 11:01 AM
New Contributor

I've been pulling my hair out for three days dealing with this, and it's driving me crazy now.

I have a server running ArcGIS Server 10.2.2 that has been running reliably for a couple of years.  I had not created or altered any services for a while, but when I did it last, maybe in April or May, it worked smoothly. This week, I went to alter one of the services running on it, as I needed to change the symbology of one of the layers slightly.  I made my changes to the .mxd, and went through the file->share->share as service dialog as I always do, but when I clicked on the publish button, I got a dialog that says this:

After some troubleshooting involving deleting the service and recreating it, I get this when attempting to publish the service:

The service is actually created, however, but just refuses to start.  Attempting to start it manually, either via the context menu in the catalog or the Manager UI, results in that same error message as seen in the first dialog.

I've tried the following to fix this issue, and nothing seems to make any difference at all:

  • Checked permissions for the .msd file it talks about.  The ArcGIS user owns the entire c:\arcgisserver tree and has "full control" access to it, but the .msd file in question doesn't actually exist.  Notably, for other services on the server, a .msd file does exist.
  • Rerun the "Configure ArcGIS Server" account wizard.
  • Checked the geoprocessing results window in Arcmap for the results.  This is what I get:
  • Checked the data connections being used for the layers in this service.  There are three layers, in the same ArcSDE 10.2 geodatabase.  I get no warnings about data being copied to the server when hitting the "Analyze" button, and the data store is definitely registered with the server.
  • Run the "Repair" procedure for ArcGIS server through the Programs and Features icon in the system control panel.
  • Installed another copy of ArcGIS server on a totally separate machine, registered the data sources and attempted to publish the same .mxd file.  Oddly, I get the same error.  This suggests the data source is the source of my problem, but I can't find anything wrong with it.
  • I turned on verbose logging, but don't get anything terribly descriptive.  It's basically just two or three more copies of that same error message from that first dialog, for every time I've tried to start the service.
  • Tried turning off the Windows firewall.
  • Tried creating a totally unrelated service, with layers from another ArcSDE database and a totally new map document.  This fails too.
  • Tried creating a service definition file, and then create the service through the manager UI.

About the server:

OS: Windows Server 2012, patches are current

RAM: 128GB

CPU: Dual Xeon E5-2643s

ArcGIS: Server 10.2.2 and Desktop 10.2.2 are installed

I'm using Desktop 10.2.2 to publish this service, but I've also tried 10.2 and 10.3.1 as well.  The version used seems to make no difference.

Any ideas about what I'm doing wrong here?

0 Kudos
10 Replies
Occasional Contributor II

We have come across this issue a few times. One thing to try is the "Save a service definition file" option in the Share as Service dialog. Once you save the sd (can be locally), log into to server manager and use the Publish Service workflow. We have found that when a specific map document is giving us issues publishing as a service, this option often works. (although it typically is only practical for new services. It requires you to delete an existing service.)

We also noticed that staggering the service Recycling times cleared up a lot of our issues. We have a lot of services running and having them all recycle at the default midnight time would occasionally cause issues with the services. Basically, the msd's within the server store would be locked, preventing us from updating the service. Once we staggered the recycle times, our publishing issues disappeared.

Hope this helps!

0 Kudos