Admin API: Could not edit service Parameters - Clearing the REST Cached fixed it

01-24-2014 10:14 AM
Occasional Contributor II
Just posting for FYI in case someone comes across the same problem...

Running Esri ArcGIS Server 10.1 SP1 in a distributed environment (2 network load balanced web-adaptors and 4 GIS servers in a 2 cluster site)

  "resources": [
  "currentVersion": 10.11,
  "fullVersion": "10.1.1",
  "acceptLanguage": "en-US,en;q=0.8"

The problem:
I was working with the ArcGIS Server Administrative API to do some simple service configurations (specifically I was knocking down the min # of instances from 1 to 0) to free up some memory resources on our dev/test environment that has a lot of web-service bloat. 

I was executing an HTTP Post that looked something like this:

with a payload like this:
{"minInstancesPerNode": 0}

and the response from the server was:
{"status":"error","messages":["Could not undeploy services from one or more machines. 'Server machine 'https://HOST.DOMAIN:6443/arcgis/admin' returned an error. 'C:\\Program Files\\ArcGIS\\Server\\framework\\runtime\\ejbs\\FOLDER\\SERVICE.MapServer\\Recycling (Access is denied)''."]}

Tried the process multiple times.  Could not find anything of significant value in the Event Viewer on the server throwing the fit. 

Couple of quick google searches resulted in someone having a similar problem and restarting the machine fixed it.  I dont want to restart the machine... so the witch-hunt started to find a less invasive solution.

The Fix:
I decided to try clearing the REST cache. 

Clicked the button Clear Cache at the following URL: https://HOST:6443/arcgis/admin/system/handlers/rest/clear

provided a good result:
{"status": "success"}

And presto... I could immediately adjust server settings again.

Hope this little write-up saves someone time.

UPDATE - It appears that my issue is still here...  It might just be one of the machines in my site that fails as the other machines are not throwing an error.  I only get the error on 1 machine in my site.  I will keep troubleshooting, but maybe rebooting just the 1 machine will work.
Tags (2)
0 Kudos
1 Reply
by Anonymous User
Not applicable

I'm having the same issue with my site. I tried your method and it worked the first time around, but when I tried changing the parameters of another service, the same problem occurred.

I have two machines in one cluster.


0 Kudos