ArcGIS Server still thinks it is federated but not showing up under federated servers...

716
5
10-13-2021 06:30 AM
ArranCoombe
New Contributor II

Hi. We currently have an on-prem installation of ArcGIS enterprise which includes, Portal for ArcGIS, ArcGIS Server and ArcGIS Datastore. 

The issue we are having is we have reinstalled the web adaptor for an Image server and provided a new web adaptor name. e.g. server1 > Imageserver. This works and is accessible when applying the webadaptor name to the end of the our enterprise URL. 

The issues start when trying to add this newly applied web adapted server as a 'federated' server. The dialogue we receive back is 'Error - server is already federated'. We have tried unfederating this server via portal manager and also the server manager to no avail. 

The main issue is  that this server does not show up under federated servers and therefore we are unable to remove it as it is not listed.

To summarise has anyone ever had an issue where they can't federate a server because it  thinks it is already federated and you are unable to unfederated it in order to apply it again?

 

Many Thanks

Arran

0 Kudos
5 Replies
HenryLindemann
Esri Contributor

Hi @ArranCoombe,

you should not unfederate your ArcGIS  Server because when you federate to the same ArcGIS server again all the items in ArcGIS Server will be re-added with new itemid's and this causes havoc to permissions links etc.

what you should do if you changed the webadaptor name is to reconfigure your federation to use the new name and update all the url's in the system with something like ago-assistant.

so if you don't have a backup of the server to repair the damage you will need to go to the answer below:

if you have backups and you would like to repair the federation let me know and I will help.

 

Answer: 

https://your_name.co.za/portal/sharing/rest 

login 

https://your_name.co.za/portal/sharing/rest/portals/0123456789ABCDEF/servers

click on the server id and UnRegister Server

HenryLindemann_0-1634133200491.png

 

Hope It Helps 

Henry

 

 

ArranCoombe
New Contributor II

Hi Henry. Thanks for the reply. I following the link towards the end of your comment and I was able to successfully unregister the federated server. So thankyou. I have now been able to add the server as federated again. I'm now having an issue where the hosting server won't validate the server managed database when validating. Any ideas as to why this may be?

 

Thanks

Arran

0 Kudos
HenryLindemann
Esri Contributor

Hi @ArranCoombe, the datastore is probably still reverencing the old url all you do is re-register it.

Go to https://your_url.co.za/webadaptor_name/manager/site.html then datastore and click on the x for relational and tile cache if present.

HenryLindemann_0-1634285817348.png

 

Then go to the server that datastore is installed on and reregister the datastores

HenryLindemann_1-1634285946455.png

This is the admin password for ArcGIS server

HenryLindemann_2-1634285980602.png

 

go to the describe tool when you are done and run it in a administrative command prompt the new URL's should reflect 


"C:\Program Files\ArcGIS\DataStore\tools\describedatastore.bat"

or where you installed the datastore app.

 

Kind Regards

Henry

 

 

 

0 Kudos
NathanEnge
Esri Contributor
Have you tried to go here and do it?
[cid:127c795a-4f85-436b-ad4d-eefb985f00bb]
Also probably doesn't have to be said, but a stop/start services as well.

Also you may need to unregister your old WA and re register the new one via ArcGIS Server Admin API
[cid:12028513-cf75-412e-a470-15050f4f119e]

JonathanQuinn
Esri Notable Contributor

If you signed into the Server Admin API and go to security > config, does it show ARCGIS_PORTAL or GIS_SERVER for the Authentication Tier property?

JonathanQuinn_0-1634148464952.png

It should show GIS_SERVER. If it shows ARCGIS_PORTAL, go to Update at the bottom and set it to GIS_SERVER.