Select to view content in your preferred language

ArcGIS Server Manager - Site Creation Error DADFLib.dll - 11.1 - Linux

455
2
10-02-2023 03:57 PM
lvargas
Occasional Contributor

Hello,

An ArcGIS GIS Server 11.1 is being installed on a new server (no apps, just the ArcGIS Server). The error occurs when trying to create the initial ArcGIS Server administrator account.

 

Failed to load /opt/arcgis/server/framework/runtime/ArcGIS//bin/DADFLib.dll.

Error code -1073741795

 

02-10-2023_15-59-20.png

 

I have searched for information online, but I don't see anything relevant.

Hypervisor: VMware vSphere 7.0

Operating System: Oracle Linux 8 (8.8)

ArcGIS Server: 11.1

 

Information:

  • The application has been installed in /opt/arcgis, it passed all checks at the time of installation. 
  • Limits were established prior to installation (soft and hard).
  • The file has the default privileges, I have checked it on another installation and at the privilege level it looks the same (and the folders privileges looks fine) (I have also tried to change the default privileges to 777 (not recommended or safe) but I have the same problem.).

  • A normal operating system account (local account on the server) is used.
  • getetx was installed.
  • Currently the certificate is the self-signed, which is created during installation because I'm stuck in the creation of the site. The certificate has been exported and added to the certificate store on the server.

I would appreciate if this community have any idea to solve this issue 🙂

 

Regards.

0 Kudos
2 Replies
zhangs
by
New Contributor

I ran into a similar problem on ArcGIS Enterprise 11.0. After investigation, I found that my virtual machine did not recognize the avx instruction set by default. This problem was solved after enabling the avx instruction set on the virtual machine by modifying the vmx file of the virtual machine.

0 Kudos
zhangs
by
New Contributor

So, is the AVX instruction set necessary for ArcGIS Server? If not, what is the root cause of this error, and are there any diagnostic methods for the issue?

0 Kudos