Portal For ArcGIS - Collector URL?

12707
22
11-19-2014 10:50 AM
Regular Contributor

Hello,

We have installed Portal for ArcGIS and would like to use Collector for ArcGIS with our Portal.

I am having issues connecting to our Portal through Collector. Is there a specific URL I need to enter.

Some Info

  • Testing this on an iPad
  • I can access the portal on the iPad though the browser
  • Using HTTPS
  • I have tried the following...

Any ideas?

Thanks,

Drew

Tags (1)
Reply
0 Kudos
22 Replies
New Contributor III

Hi Andrew,

this sounds like a problem with your ssl-certificate. You need to install the certificate of your webserver on your ipad to successfully login. To do so export the Certificate maybe from your browser send the certificate by mail to your ipad an click on it.

If you need more detailed information about how to bring the certificate to your ipad just let me know.

-

Regular Contributor

Thanks for the reply Rainer.

We did have all sorts of SSL issues when configuring Portal. We did federate the server and that causes some certificate issues too. I will give your suggestion a try.

Would this be common practice moving forward if it works or should I look at the certificate a little closer?

Thanks again.

Drew

Reply
0 Kudos
New Contributor III

Hi Drew,

IT is unfortunally necessary if you are using your own ca or a selfsigned certificate. To avoid this additional steps you need your certificate to be signed by a trusted ca like thawte or startssl.

I hope this helps,

-

Von: Andrew Timmins

Gesendet: Donnerstag, 20. November 2014 19:42

An: Rainer Spitzer

Antwort an: jive-303489768-y3i-2-9fbh@mail.geonet.esri.com

Betreff: Re: - Portal For ArcGIS - Collector URL?

GeoNet <http://jiveon.jivesoftware.com/wf/click?upn=Dg1s4x8le7Lmxv8KWGaqo8h7SGfRSMkw-2FpvHGF9-2FW3rK-2Bvs1kL9-2FnG6jjf2NZhrLDz0M-2BrY-2By9IaziQEKVk3Hg-3D-3D_2vEmGfTv6NF9ysi44XFDLSmAR8EbLECDBSNjtoNhoJc7nstNZq8TQ3olFaKHjkV0JY93Dl1NCEdlSAxI-2BzElmet8Vv9K-2FhATatdwY1vybLkf2fKUlp8Hr3fnyWEFWjVVN7h9p-2BfXNLoWL2-2B8jhCC-2BB-2B4qoW7d5rew2B3uvq9yS1pyQqKZSuhOtm1vP-2FbsFMQSQ8Nl3OUU1W-2FdPmR8mHimm06AItM6llCtIB-2B3etU7C-2FELZQI1S9DejL2tUWLpFvtPfSJ3C49S2R5rAZbYU109fWA2rfevUHp4GLQdxaCVzGZbSaFEF1f4pPXCKN8PNWi>

Portal For ArcGIS - Collector URL?

reply from Andrew Timmins<http://jiveon.jivesoftware.com/wf/click?upn=Dg1s4x8le7Lmxv8KWGaqo7A4BXwO9PY1WvQ5cXCtK4-2FlQsrl0uao8P-2FakcevGyI3Ifw4yOHHvAIA3gbAJVGi35QgBfOeybhZk7ru1LgAhdA-3D_2vEmGfTv6NF9ysi44XFDLSmAR8EbLECDBSNjtoNhoJc7nstNZq8TQ3olFaKHjkV0JY93Dl1NCEdlSAxI-2BzElmet8Vv9K-2FhATatdwY1vybLkf2fKUlp8Hr3fnyWEFWjVVCGY-2B823Z3ZVwQnx4KacMMten8CqBYR7bbHda6XwmI-2FJE18cpa6zZcup0XRF-2Bc3QrbjLHdLctWlhQNf6EVcxkxlN-2FR0kDPWoGaZLFt73NHVbtdPajBRYBARLcfSFJLKZlfSYLqzj85etfbiQh3GcDNjOaQyZ2F8-2F84SP70rB8zT3SsRBlRDYb4sJbgaNtkhVP> in Portal for ArcGIS - View the full discussion<http://jiveon.jivesoftware.com/wf/click?upn=Dg1s4x8le7Lmxv8KWGaqo0VQjeJBYpG9HGC8QZBT-2FEyBFOkFCnASCCZjjSvlKqwNpLqRpHq1i2U-2BZXoilgsc5w4CHMq-2Bu4cS5WrXT3bzwWk-3D_2vEmGfTv6NF9ysi44XFDLSmAR8EbLECDBSNjtoNhoJc7nstNZq8TQ3olFaKHjkV0JY93Dl1NCEdlSAxI-2BzElmet8Vv9K-2FhATatdwY1vybLkf2fKUlp8Hr3fnyWEFWjVV7uCGsTGZqdY6FWG1XnK9Ky47WQHzCw55lWYXrgz-2F4zCRQrIZ9nglbaTAkhmWVojtcJofNeieF-2FjylDT1DYvD8jXUyEUxTSFxTWzDMLHM-2BtBueW7uicl-2FQD9J3M3jmzhSGokoDIdAfbGbli-2F9AnzSpgd7qAzapiyx3-2B7ewGleEQNcdk3pHmo9Cy4GHhIX0UTT>

Reply
0 Kudos
New Contributor II

I installed the certificate and I am still being prompted for username/password. I will not accept anything including the Admin log on. Any ideas?

Reply
0 Kudos
Regular Contributor

That sounds like you might have some issues with IWA?  or is it a Linux setup?

I'm working through similar issues except I can get in fine (usually) but other users have issues.

It appears to be related to the security settings in Portal and IIS.

Reply
0 Kudos
New Contributor II

I am having the same issue! I installed the SSL certificate and still is not letting me get to portal. Have you had any luck?

Reply
0 Kudos
Regular Contributor

Lisa,

when you visit the website using HTTPS does it look like you have a valid certificate?

In Google Chrome you should see a lock in the address bar, just like GeoNet has right now as you read this message.

You can click on that lock and get more information about the certificate.

I believe once we got a signed certificate we were able to login fine.

Drew

Reply
0 Kudos
Occasional Contributor

Did you get this issue resolved Lisa?  We are having the same issue.  Everything seems to be fine with our SSL cert.  I can visit the portal site on an iPad, but when I try to login to collector it says "unknown error occurred" 

Reply
0 Kudos
Esri Regular Contributor

Curious, but Cort, what security is used in Portal? I.e. Is it a built-in named user or windows credentials or SAML (ADFS)?

Reply
0 Kudos