Survey123 & Portal for ArcGIS

4950
11
12-15-2016 01:59 AM
MiraEl-Koussa
New Contributor III

Greetings all, 

I am having issue while adding the url of my portal in survey123.  I am using portal 10.4.1

I did everything as mention in the following URL : https://community.esri.com/groups/survey123/blog/2015/07/29/survey123-and-arcgis-for-server 

However, when i try to add the url in the survey i get the following error: 

Survey 123 requires that portal .........with a hosted server and arcgis data store. 

server is federated and hosted on the portal. 

Data store is configured. 

Please any help or idea is appreciated cause i dont know where to look anymore. 

11 Replies
DerekLaw
Esri Community Moderator

Hi Mira,

Have you tested that you've set-up and configured Portal for ArcGIS with a hosting server and the ArcGIS Data Store correctly? Can you add a shapefile and create a hosted feature service in Portal?

This help topic might be useful as well: Use Survey123 with Portal for ArcGIS—Survey123 for ArcGIS | ArcGIS 

Hope this helps,

0 Kudos
MiraEl-Koussa
New Contributor III

yes I did and everything is working fine. 
However, whenever I try to connect the portal with Survey123, I get this error. 

I did go through the help topic and I did everything as described. 

any other possible issues ?

0 Kudos
DerekLaw
Esri Community Moderator

Hi Mira,

Which component of Survey123 are you trying to sign into your Portal? Survey123 Connect or the Survey123 mobile app?

0 Kudos
MiraEl-Koussa
New Contributor III

Survey123 Connect

0 Kudos
DerekLaw
Esri Community Moderator

Hi Mira,

FYI: if you've configured Portal for ArcGIS with a hosting server and the ArcGIS Data Store correctly, there are no additional parameters or settings that need to be set in the Portal sharing API to enable Survey123 to work.

Since you're using Survey123 Connect, try this to get more info on the issue.

1. Open Survey123 Connect.

2. In the lower left corner of the UI, click the gear icon to open the Survey123 Connect Settings dialog.

3. Click Diagnostics.

4. Click the Logging switch button to turn on logging. Ensure you know the location of the log file.

5. Click OK.

Now try and sign into your Portal for ArcGIS instance and after you get the error, navigate to the log location and view the log file. There may be some useful information there.

But as I've said, I suspect something is NOT configured correctly with your Portal for ArcGIS with hosting server and the ArcGIS Data Store. If you can't see any useful information in the log file, please contact Esri Tech Support and they can help you investigate further.

Hope this helps,

0 Kudos
DanielUrbach
Occasional Contributor II

If you go to https://yourportal.yourdomain.com/webadaptorName/sharing/rest/portals/self (fill in your FQDN and web adaptor name in there), what is the value of 'supportsHostedServices' and 'hostedServerHostedFolder' ?  You may need to sign in to see these values.

0 Kudos
MiraEl-Koussa
New Contributor III

Greetings, 

Kindly note that those are the value of the fields u mentioned in ur reply :

supportsHostedServices: true

hostedServerHostedFolder: Hosted

are these value true ? is there anything else i should check. 

0 Kudos
DanielUrbach
Occasional Contributor II

Mira,

Thanks for the response.  I looked at the Survey123 source code in AppStudio and it looks like it is also checking for the "supportSceneServices" attribute.  Can you confirm if that is present and if it is set to true?

0 Kudos
MiraEl-Koussa
New Contributor III

Hi Daniel, 

Thank you for your continuous support.

This field  "supportSceneServices" is not present in the path  https://portal.domain/webadaptor/sharing/rest/portals/self 

what to do next? 

0 Kudos