Creating initial Portal administrator account using 10.3.1 AMI on Amazon Web Services (AWS)

4096
4
Jump to solution
06-17-2015 07:40 PM
PaulHaakma
Regular Contributor

Hi. Has anyone else successfully got Portal going using the latest 10.3.1 server AMI on Amazon Web Services?

I have created a server using this AMI, which comes with Portal pre-installed. The documentation (link below) says to go to the following address to set up the initial administrator account:

https://<fully qualified machine name>:7443/arcgis/home

This address just comes up in the browser as 'This webpage not available, ERR_CONNECTION_REFUSED'.

I have tried using the ip address, computer name, AWS public name, and a public domain name that I have created (and that has the SSL cert bound to). None of these get to the portal page.

Going to https://localhost/portal or substituting the AWS public name or the public domain name for 'localhost' all redirect to the webadaptor configuration page which is https://localhost/portal/webadaptor  but of course I can't configure the web adaptor without first setting an initial administrator account.

I am following the documentation at http://server.arcgis.com/en/portal/latest/administer/windows/deploy-portal-on-aws.htm

Any ideas?

Cheers,

-Paul

0 Kudos
1 Solution

Accepted Solutions
PaulHaakma
Regular Contributor

Hi Daniel - thanks for your reply. Very sorry, I forgot to update the post as someone helped me troubleshoot from elsewhere.

The issue was that the Portal service had been started, but not set to 'Automatically start', so restarting the server had turned that service off again. Setting it to automatic has solved the issue.

(on to the next issue now... Federating Portal! but that's another discussion...)

Thanks again for your time.

-Paul

View solution in original post

4 Replies
JayantaPoddar
MVP Esteemed Contributor

Hi Paul,

The initial administrator configuration page should come up just after installation of Portal for ArcGIS.

What page are you getting when you enter https://localhost:7443/arcgis/home

What is your fully qualified machine name?



Think Location
0 Kudos
PaulHaakma
Regular Contributor

Hi Jayanta

No page loads at all. The error that comes up in the browser is that the connection is refused/rejected.

This webpage is not available

ERR_CONNECTION_REFUSED

I previously upgraded a 10.2 installation of server (which did not have Portal installed) to 10.3 and then installed Portal, and the link that worked was:

https://ec2-xx-xx-xx-xxx.ap-southeast-2.compute.amazonaws.com:7443/arcgis/home

which is the elastic IP of the server. But it does not work on this instance, which was based on an AMI provided by Esri which had Portal pre-installed. The server name is win-fur97r87gbu

0 Kudos
DanielUrbach
Occasional Contributor II

Hi Paul!

If you go to your AWS Console and look at that AMI, does it have a public DNS name assigned to it? (It should look similiar to the one you mentioned above)

If not then you will need to set up an elastic IP for the server in the same way you did with your other server which worked for you.

Can you also confirm that the security group in AWS that your server is a part of has port 7443 available?

0 Kudos
PaulHaakma
Regular Contributor

Hi Daniel - thanks for your reply. Very sorry, I forgot to update the post as someone helped me troubleshoot from elsewhere.

The issue was that the Portal service had been started, but not set to 'Automatically start', so restarting the server had turned that service off again. Setting it to automatic has solved the issue.

(on to the next issue now... Federating Portal! but that's another discussion...)

Thanks again for your time.

-Paul