Enabling HTTP and HTTPS on Arcgis Server so can federate with Portal

3695
4
Jump to solution
06-24-2015 06:17 PM
PaulHaakma
Regular Contributor

Hi. I am trying federate Portal with Arcgis Server.

Both Portal and Server are fresh installs on Amazon using the latest 10.3.1 AMI from Esri. (They are on the same EC2 instance).

Portal is set to not require HTTPS. There is an SSL cert installed on the webserver it is on.

The documentation says to change Server to allow both "HTTP And HTTPS", but as soon as I do this, any attempt to login in to the Server Manager (note that the ELB does not has SSL enabled) redirects to HTTPS and fails to load.

Any attempt to federate Portal with this Server then fails, I assume because of the above reason.

Any idea why setting Server to allow both HTTP and HTTPS would cause Server Manager to no longer load?

Cheers,

-Paul

0 Kudos
1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

Hi Paul,

Try this:

1) Open the webadaptor page with http/https account (https://<MachineName.Domainname>/<WebAdaptorName>/webadaptor)

2) Configure ArcGIS Server with the https (port:6443) url. (https://<MachineName.Domainname>:6443)

Restart ArcGIS Server service, if required.

Let me know if the issue still persists.



Think Location

View solution in original post

0 Kudos
4 Replies
JayantaPoddar
MVP Esteemed Contributor

Hi Paul,

Try this:

1) Open the webadaptor page with http/https account (https://<MachineName.Domainname>/<WebAdaptorName>/webadaptor)

2) Configure ArcGIS Server with the https (port:6443) url. (https://<MachineName.Domainname>:6443)

Restart ArcGIS Server service, if required.

Let me know if the issue still persists.



Think Location
0 Kudos
PaulHaakma
Regular Contributor

Hi Jayanta

Success! Thank you, yes your instructions worked.

As I understand it, the issue was with the setup of the web adaptor for Server needing to know that https was enabled. Once that was fixed, the federating with portal went ahead no problems.

Thanks again.

Cheers,

-Paul

DanielUrbach
Occasional Contributor II

Paul, is this on an Ubuntu AMI by any chance?  There is a bug logged for this exact behavior.

If you access the manager page using https in the first place, does it load properly?

Also when it redirects to https, what is the URL it is redirecting to?

0 Kudos
PaulHaakma
Regular Contributor

Hi Daniel

Thanks for your reply - see Jayanta's post above which turned out to fix the issue I was having.

Cheers,

-Paul

0 Kudos