Configure Fields in Standalone Tables

151
5
09-16-2021 09:08 AM
DanteLee
Occasional Contributor II

I've published a service with a standalone table to Portal (10.6), and I'm wondering if fields in standalone table can be configured like layers can? For example, I'd like to remove the thousands separator; or format the date field a certain way.

Peaking into AGO Assistant, I only found configurations for the layers and not any tables. Ideas?

0 Kudos
5 Replies
RobertBorchert
Frequent Contributor III

Just open the Configure Attributes for the table as would for a feature class.

RobertBorchert_0-1632233852717.png

 

0 Kudos
DanteLee
Occasional Contributor II

Thanks. Are you doing this within a web map? I'm looking to configure the service without creating a web map. Or maybe it's cuz I'm in 10.6 - I don't see an option to do it on the feature layer

0 Kudos
RobertBorchert
Frequent Contributor III

In order to save changes like not showing the thousands separator you would have to save it. And it would save it as a Web Map.  

As far as I know the option for that has been around for a long time, i.e. since before 10.7

Are you sure the field is a Number field?  Go to its properties and make sure it isn't a String with was populated with commas.

 

https://support.esri.com/en/technical-article/000024156

 

0 Kudos
DanteLee
Occasional Contributor II

No, I understood you - I see it's possible to do within a web map. I'd like to do it without a web map (e.g. in the Visualization settings for the feature layer like you can for non-table layers). Thought maybe you could do it in the JSON for the service. But it doesn't sound like either of those is possible

DanteLee_0-1632236860265.png

 

0 Kudos
RobertBorchert
Frequent Contributor III

In my my opinion ArcMap is superior for serious editing.

However, ArcGIS Pro, is superior for creating feature services and web maps.

If you use Pro in the Design >  Fields dialog you can designate whether or not the thousands separator is showing for a numeric field 

 

RobertBorchert_0-1632237593264.png

 

0 Kudos