Web adaptor for portal

7195
8
Jump to solution
01-27-2015 05:09 PM
JoeCollin
New Contributor

I insatlled portal on a internal sever behind our firewall. Opened port 443 enabled ssl. Configured web adapter on web server which sits outside of the firewall. When everything is configured correctly everything works correctly on the inside of our network. But when accessing it from the outside reaching the portal is good but hitting the sign in it redirects it back the the url with the machine name of the web server and that sign in page will not load has anyone else seen this.

0 Kudos
1 Solution

Accepted Solutions
khairulamri
Occasional Contributor

Hi Joe,

make sure your domain alias has configured correctly on your portal instead of machine name.

here is the steps :

1. login to portal admin : https://yourmachinename.domain:7443/arcgis/portaladmin

2. click system > web adaptors > you will find your webadaptor name. click the web adaptor name, you will get the url like this https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8 (this is random id, maybe different in your machine)

3. in the browser append /edit to the end of the URL like this : https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8/ed...  then push enter.

4. edit Web adaptor URL, change with your domain.  by default the url is machinename > click web adaptor. the portal is restarted, wait for the portal to restart before proceeding.

register domain.png

-amri-

View solution in original post

8 Replies
khairulamri
Occasional Contributor

Hi Joe,

make sure your domain alias has configured correctly on your portal instead of machine name.

here is the steps :

1. login to portal admin : https://yourmachinename.domain:7443/arcgis/portaladmin

2. click system > web adaptors > you will find your webadaptor name. click the web adaptor name, you will get the url like this https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8 (this is random id, maybe different in your machine)

3. in the browser append /edit to the end of the URL like this : https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8/ed...  then push enter.

4. edit Web adaptor URL, change with your domain.  by default the url is machinename > click web adaptor. the portal is restarted, wait for the portal to restart before proceeding.

register domain.png

-amri-

JoeCollin
New Contributor

amri

that did seem to correct the domain as it appears to be correct on the outside but the sign in page still does not load simply gives me a page will not load basic connection timeout error.

I Verified that the port is open and ssl is enabled. With this page not loading the collector app will not work

is there anything else you can think of

thank you so much for you help

joe

0 Kudos
khairulamri
Occasional Contributor

Joe,

I also got same problem and resolved using the steps above. have you tried to restart the Portal for ArcGIS service?

0 Kudos
JoeCollin
New Contributor

Khairul

Thank you for all your help, I did make the changes you suggested which in the end help but the real problem came on the end of my IT guys having to enable the HTTPS on the firewall after I had requested and asked them for 3 days making sure there was nothing blocking me.

Thank You again

Joe Collin, GISP

Auglaize County GIS

GIS Coordinator

419-739-6730 (Office)

937-524-9310 (Cell)

0 Kudos
DianaBenedict1
New Contributor III

Thank you Amri for providing the very useful tip on how to edit the Portal Web Adaptor configuration information located in the /portaladmin page. I have had to use this "trick" several times for our initial install on various environments (DEV/UAT/PROD) and for upgrading those environments. 

I would like to understand why we need to do this? I have asked some of our infrastructure folks but they are not sure why this is the case. Do other folks run into this issue as well?

My servers are configured as follow:

- note that these are all INTERNAL access only, not outside firewall, hence why the WebAdaptors are on the same server (for now).

Server 1: (cname: myCoolPortal.mydomain.org with SSL cert SAN using the cname)

- Portal installation

- Web Adaptor for Portal

Server 2: (cname: myCoolGisServer.mydomain.org with SSL cert SAN using the cname)

- ArcGIS Server installation

- Web Adaptor for Server

Server 3: (cname: myCoolDataStore.mydomain.org with SSL cert SAN using the cname)

- DataStore

I think that this must have something to do with some special config in the inners of Portal that is using the servername instead of the fancy cname. Everytime I configure the web adaptor or portal urls I give it my fancy cname not the server name but for some reason the servername is configured in the portaladmin system > webadaptors section and I need to edit it with the cname. Is there a place in Portal that I can check for this and make the change permanent? 

Thanks for any insight you can provide.

Cheers

Diana

0 Kudos
JonathanQuinn
Esri Frequent Contributor

The URL you use to reach the web adaptor registration page, (https://webadaptor.domain.com/portal/webadaptor/portal) is the URL that's set for the Web Adaptor URL. If you have a machine with a hostname and alias, ex wa.internal.com and webadaptor.acme.com, you should reach the web adaptor registration page via webadaptor.acme.com, not wa.internal.com. The web page brought up after the install likely defaults to the internal name.

0 Kudos
NickHarvey
Occasional Contributor II

@khairulamri  - Amri - Thank you so much!  This worked for me..Including the reminder to restart the Portal service. 

Best,

-Nick  

0 Kudos
khairulamri
Occasional Contributor

Joe,

I'm glad to hear that. for the future if you want to check the port has opened or not you could use telnet command from client side.

Warm Regards

0 Kudos