Cannot view published hosted tile layer in Portal for ArcGIS

884
2
10-06-2017 10:08 AM
JulieRoebotham
New Contributor III

I have a .tpk that i have uploaded to both ArcGIS Online and Portal for ArcGIS. It follows the ArcGIS Online tiling scheme but I've added the 1:564.248588 tile level. i can share the tile package to ArcGIS Online and Portal for ArcGIS without issue. When I publish the tile package in ArcGIS Online it displays fine, but when i publish in Portal for ArcGIS the hosted layer is 1kb, is not visible in a web map and i don't have the option to build or manage tiles on the settings tab for the hosted layer.

I know it isn't the location of the tiles / permissions because i have another .tpk that published fine and can be viewed in ArcGIS Online or Portal for ArcGIS.

Portal is federated with server, and the tiles that the .tpk was created from are visible in the server cache directory - so i can only assume the .tpk is fine (especially since it works on ArcGIS Online). The extent of the hosted service in portal also seems to be correct. 

Can anyone think of anything i'm missing? Is there a reason why Build Tiles is not available in the settings tab in  Portal?

Thanks!!

2 Replies
StevenE
New Contributor III

Did you ever find a solution to this? I'm having the same issue and I cannot figure out what else I might try to fix the issue. Thanks.

0 Kudos
MichaelAugust
Occasional Contributor III

I am having an issue where I've uploaded a .tpk to Portal, either through arcmap share as>tile package or through the geoprocessing tools.  The tpks upload fine but when I hit publish I get the best error ever: "There was an error." when I hit the publish button.  The hosted layer is created but just sitting there, it won't display in any webmaps, etc. looks ok but doesn't work. Wondering if either of you figured out your issues? Thanks!

0 Kudos