Select to view content in your preferred language

Can't select features and open attribute table for map image layers in ArcGIS Pro.

2396
6
Jump to solution
06-05-2023 01:57 AM
Labels (3)
SjurKlemetsen
New Contributor II

When I open map image layers from the portal in ArcGIS Pro, I am unable to select features and open the attribute table. I am able to open the the pop up for features using the Explore tool, but nothing else. Is this how its supposed to be, or am I doing something wrong? 

 

I am using ArcGIS Pro 2.9. I tried to update to 3.0, but it still didnt work. My company uses a concurrent license, and we use arcgis enterprise to share maps and features. I am able to open the attribute table for our feature layers. 

Thank you! 

0 Kudos
1 Solution

Accepted Solutions
AndreasHall
Esri Contributor

As far as I understand this is expected behavior. You need a feature service (feature layer) to be able to select objects in ArcGIS Pro. You can enable feature access capability on your map service in ArcGIS Server Manager to achieve this.

View solution in original post

6 Replies
AndreasHall
Esri Contributor

As far as I understand this is expected behavior. You need a feature service (feature layer) to be able to select objects in ArcGIS Pro. You can enable feature access capability on your map service in ArcGIS Server Manager to achieve this.

SjurKlemetsen
New Contributor II

Thank you very much 😀

0 Kudos
TanuHoque
Esri Regular Contributor

hi @SjurKlemetsen,

As @AndreasHall mentioned, unfortunately that is a known limitation. Good news is that it is in production plan.

you can follow it here in this idea: https://community.esri.com/t5/arcgis-pro-ideas/arcgis-pro-2-4-2-exporting-data-tool-from-map/idi-p/9... or with this enhancement ID - ENH-000131766. You can also add your requirements, workflows etc. if you want to.

 

You need a feature service (feature layer) to be able to select objects in ArcGIS Pro. You can enable feature access capability on your map service in ArcGIS Server Manager to achieve this.

A quick note on this - you don't necessarily need to enable feature access capability to add a layer of a map service (aka map image) layer as a feature layer in Pro (or even any web client app). When you add a layer in Pro (or in a web app), you need to use a layer url (instead of map service url).

E.g.

 

please let me know if you have any questions.

 

SjurKlemetsen
New Contributor II

Got it. Thank you. 😀 So it is not possible opening the attribute tables as well? 

 

0 Kudos
TanuHoque
Esri Regular Contributor

@SjurKlemetsen unfortunately that is correct; I'm hoping you won't need to wait too long to get the functionality included in ArcGIS Pro, as it is in the production plan

0 Kudos
SjurKlemetsen
New Contributor II

Got it. Thank you very much! 

0 Kudos