arcgis server 10.5 web adaptor for portal

992
2
08-30-2017 07:24 AM
youngpark
New Contributor III

Good morning,

 

I have a simple question about web adaptor setting for my new arcgis portal.

In a machine(AWS), I installed Arcgis Server 10.5, Portal 10.5, GeoEvent server 10.5, web adaptor 10.5 (arcgis/portal)

I can access the server (server manager with web adaptor, geoevent without web adaptor) from a different network.  Unfortunately, not the portal site.

 

Question is as follows.

  1. I was able to setup web adaptor for ArcGIS server then, I can access to the manager site https://xxxxx/arcgis/manager from a different network. I could not configure web adaptor(arcgis) for Portal.  When I select the PORTAL, server returns HTTP 400 error. 
    Thus I created an additional web adaptor (portal), however, I am getting the same error.  
    And, I can access to portal site with port number from the server.  However cannot access to the port site from a different network.  It will redirect the “address from domain.name:7080/arcgis/home” to “computer.name:7080/arcgis/home”

 

If you have any suggestions please guide me to the right direction.

 

Thanks,

0 Kudos
2 Replies
JonathanQuinn
Esri Frequent Contributor

You should be using two separate web adaptors, (arcgis for Server and portal for Portal, for example):

Can I configure the same ArcGIS Web Adaptor to work with both ArcGIS Server and Portal for ArcGIS?

So when you install the portal web adaptor, reaching https://<machine>.<domain>.com/portal/webadaptor returns a 400?

0 Kudos
youngpark
New Contributor III

hi Jonathan,

I do understand i cannot share the web adaptor for the portal and the gis server.  when I access to " https://<machine>.<domain>.com/portal/webadaptor"  my browser cannot find the page at all.

http://machinename/portal/webadaptor returns the web adaptor setting page, but I am getting the 404 error when I select the "portal".

https://machinename/portal/webadaptor returns following message "The web adaptor configuration URL has to be accessed from the machine hosting the web adaptor."

thanks in advance,

Young

0 Kudos