ArcGIS Portal Publishing SLPK Hosted Service Issues

708
2
11-27-2018 10:24 PM
StephenYates3
New Contributor

Hi all,

First post here.

I have a fully setup ArcGIS Enterprise (10.6.1) - Portal, server, web adapters etc

All sit on the one server.

I can publish anything to the portal and have hosted services created without issue.

My one issue is when trying to publish SLPK files. Admittedly they are large (around 4 gig each). So I can't share them from ArcGIS Pro like normal. I use the Share Package tool and upload it to my portal. The user I am connecting as has full administration rights on portal and server.

Once it's uploaded, I do not have a 'Publish' button in order to create a hosted service and build some sweet scenes and apps.

I have double checked the data stores and both the managed database and tile cache setup and validated.

The enterprise is federated with the webadaptors and due to being able to send feature data and services up (both referenced and copied) to the portal without issue has me perplexed. Note the lack of 'publish' button:

Portal Lack of Publish Button

I can't seem to find anyone else with the same issue.

Cheers.

Steve.

0 Kudos
2 Replies
PaulCollins
New Contributor

I am currently struggling to understand this as well.  I have an identical ArcGIS Enterprise setup only I am on 10.6 .  I have been able to upload an albeit smaller SLPK file through my Portal and I have also used the Share Package tool.  Both times I have no option to publish it as a layer.  When have loaded the same SLPK into my organization's ArcGIS Online instance and there is an option to publish the SLPK as a hosted layer right from the Add Item dialog box (see image below)

ArcGIS Online Add Item From Computer

This is frustrating.  Hopefully Esri will ensure that this capability exists in Portal as well.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Open the dev tools or run Fiddler when loading the page for the slpk. A request is made from Portal to the Admin API to check whether the hosting server has a tile cache data store registered. If that request fails or doesn't return expected results, then the Publish button won't appear.

0 Kudos