Select to view content in your preferred language

ArcGIS portal last login

1466
6
Jump to solution
05-16-2023 12:15 PM
chill_gis_dude
Occasional Contributor

Does anyone know how to accurately see when users last logged in? I know that on the Portal website you can see a "last login" field from clicking on the organiztion>members list, but I've recently learned that this does not account for mobile logins. We have users that show "never" under last login simply because they are field workers and only use the mobile app. This kind of defeats the purpose of that functionality if you have mobile users.

0 Kudos
1 Solution

Accepted Solutions
MarleyGeddes
Esri Contributor

@chill_gis_dude - there is a known issue in ArcGIS Enterprise 10.8, 10.8.1 and 10.9 where the members last login date is not updated consistently. There is a defect for tracking this issue, BUG-000129529, which is resolved in 10.9.1.

The fix for this issue is included in the lastest Portal for ArcGIS Security patches for 10.8.1, but there is no equivalent patch available for 10.9.0. 

View solution in original post

0 Kudos
6 Replies
DavidPike
MVP Frequent Contributor

Ah I see this on AGOL quite often and always thought it was a quirk or SAML auth for first-time logins.  Always seems to catch-up after a day or so or maybe after their second login.

What version of Portal are you on?  The user report export may have better detail than the GUI (I appreciate the GUI runs off the REST interface but there might be some quirks in the interpretation).

Are you comfortable using the Python or REST APIs to query against?  Some Pro notebooks might be an option to try also.

0 Kudos
chill_gis_dude
Occasional Contributor

Hey David, thanks for your response. 

We are using 10.9.0. And we aren't super savvy with REST API's but we do a lot with python. iIf there's a python script that shows this we would totally take advantage of it. 

 

George

0 Kudos
DavidPike
MVP Frequent Contributor

You can try and create a report through the GUI first.  Might still have the 'Never' problem but it's worth a try. 

https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/whats-new-in-arcgis-enter...

The 'member' report has a last login column.

0 Kudos
chill_gis_dude
Occasional Contributor

Thanks David, this will probably help us with some other administrative issues.

I just gave it a shot and unfortunately it looks like the report generated shows a last login date as Dec. 31 1969 for users who have only logged in on mobile. 

0 Kudos
MarleyGeddes
Esri Contributor

@chill_gis_dude - there is a known issue in ArcGIS Enterprise 10.8, 10.8.1 and 10.9 where the members last login date is not updated consistently. There is a defect for tracking this issue, BUG-000129529, which is resolved in 10.9.1.

The fix for this issue is included in the lastest Portal for ArcGIS Security patches for 10.8.1, but there is no equivalent patch available for 10.9.0. 

0 Kudos
chill_gis_dude
Occasional Contributor

Thank you Marley!