map zoom level when clicking on item list

3904
16
Jump to solution
12-15-2017 11:38 AM
MikeOnzay
Regular Contributor

Is it possible to set the map to zoom to a particular level when clicking on an item in a list?

16 Replies
AliciaRitzenthaler
New Contributor III

I've made a copy of my dashboard and tried editing the json to add the "pointZoomScale": 10, line however after saving and reopening the dashboard no change. When I tap my list, all other points still disappear leaving only the one, but my map does not zoom into that point at all (which can make it extremely difficult to find). 

Where exactly does the pointZoomScale need to be added into the json? If it's in the correct location (I've tried it in the following 2 places), is there an configuration I'm missing in the dashboard?

Thanks!

Alicia

Line 6

 

Line20

 

Reply
0 Kudos
DerrickWestoby
New Contributor III

It looks like you're in the correct spot, but a zoom level of 10 would put your eyeball right up against a grasshopper's kneecap. 

Try something like 1,500, and make sure you don't have a filter action that is filtering your other points (or filtering a list that has it's own filter action, etc).  You should be able to change the point zoom scale in the dashboard map's settings once you change it in the JSON (in my experience). 

Reply
0 Kudos
WilliamTrachtman
New Contributor III

Is there a conversion of pointZoomScale values to the pre defined zoom levels on a map?

Reply
0 Kudos
MelanieDuncan
New Contributor II

What version of Portal are you all using? I am using 10.7 right now, and over-writing the json for the pointZoomScale from 10,000 to 1,500 has no affect on my dashboard. I am using a list widget for a point layer with the Zoom set up.

Reply
0 Kudos
ElizabethAyarbe
New Contributor II

I am trying to troubleshoot this question as well but with polygons. The answer states that the map should zoom into a polygon and that is not true. How do we change this for polygons? Thank you in advance!

Reply
0 Kudos
WilliamTrachtman
New Contributor III

Elizabeth Ayarbe, I was never able to get polygons to work.  I made invisible points inside each polygon, then I used one point zoom level that was the best fit for viewing the polygons.  It is a work around, but it gets the job done and it looks like it is zooming in on the polygons.

Reply
0 Kudos
ElizabethAyarbe
New Contributor II

Thank you for your quick response. I'll try doing the same. I was also thinking of creating a negative buffer that falls within the polygon feature and use that as my feature to zoom to. I'll see which one works best. Thank you again!

Liz

Reply
0 Kudos