Map extent wrong on Dashboards

1452
10
05-07-2020 05:46 AM
MarkCooper5
Occasional Contributor II

Hi

I have got a map in a new dashboard I have set up and it is not using the extent from the webmap. Is there a different place this needs to be set as I cannot find it? At the moment it appears to be using the whole of Europe, which is not the map, organisation or organisation region extent.

Thanks

Mark

Tags (1)
10 Replies
DerekLaw
Community Moderator

Hi Mark,

> I have got a map in a new dashboard I have set up and it is not using the extent from the webmap.

Are you using ArcGIS Dashboards in ArcGIS Online or in ArcGIS Enterprise? If the latter, which release? I'm not currently aware of any issues with dashboard not honoring the map extent of a web map in ArcGIS Online.

0 Kudos
mpc
by
Occasional Contributor

We've got the same problem and have upgraded to Portal 10.8.1 (from 10.6.1) and it's still present, but appears to only be an issue for our own Vector Tile basemaps.

A few things I've noticed:

  • we have a basemaps group with Esri 102100 and NZTM 2193 basemaps in it. Dashboard isn't able to interchange between them
    Mark_Peacey_1-1625099121932.png
  • If the basemap is set to a NZTM 2193 basemap the following error appears on loading the dashboard:
    Mark_Peacey_2-1625099313921.png

 

When testing various things, in 10.8.1 when I set the Organization -> Map Defaults -> Default Extent, update the extent values, save it and get the "Default extent updated successfully" message, if I then refresh the page or go out of settings it defaults back to:

Mark_Peacey_0-1625095185048.png

Is there anywhere I can manually override it?

Thanks

0 Kudos
JustinPlatt
New Contributor

Has any progress been made on this issue? It is now nearly 2 years since it was reported in this string and I am still having the problem as stated by Mark. A resolution would be greatly appreciated.

0 Kudos
DerekPhyn
Occasional Contributor

I've also had this problem in ArcGIS Online. Default webmap extent is just for part of New Zealand but in the dashboard when I open it or select/unselect items in the dashboard the map extent keeps reverting to a huge part of the South Pacific. Default Extent and Bookmarks is checked on in the Dashboard map settings. I suspect there must be a default extent for one of the contextual feature layers I am using in the webmap that is set for a very large area and while the webmap honours the default extent I set up the dashboard will default to the largest extent of any layers used in the webmap? Have not had this issue with other dashboards before. Just this one.

0 Kudos
Stern_Zachary
New Contributor

I'm also having this issue

0 Kudos
CarolineBroughton
New Contributor II

This is still an issue several months on. It doesn't consistently happen for me so I assume it is a bug. Is Esri aware of this issue?

0 Kudos
NO
by
New Contributor

I am also having this same issue, on AGOL dashboard.

0 Kudos
GlasgowGISGlasgowCityCouncil
New Contributor

I am also having this issue

 

0 Kudos
mpc
by
Occasional Contributor

Apparently this is a known bug https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDEzMzUyMA== which won't be fixed for a while.

0 Kudos