Does ArcGIS Dashboard support for Database Spatial Views published as Service with Feature Access?

667
5
09-04-2020 02:00 AM
ZikoAH
by
New Contributor

Hi.

I am using ArcGIS Enterprise 10.8 , and I am trying to build  ArcGIS Dashboard by utilizing a feature services published based on Oracle database Spatial views that are registered with ArcGIS Server.

My proplem is the following.

1. Not able to visulize the feature service of those published views either by opening them in the map viewers or dashboard though I can list the attributes. Also when trying to select any attribute it shows the message "Not able to access ). Taking in consideration that for the same services I can without a problem visulize the map service. So my proplem is accessing the feature service and visulize it.

It seems that actions inside the dashboard are requiring a service with feature access , that's why we are trying to use the feature service and not the map service. Also as we are depending on spatial views we do need those spatial views to be published as feature services.

Any feedback from ESRI about this? Or if anyone face such problem and find a workaround we would appreciate sharing the solution.

Note: it's mentioned by ESRI Documentation that spatial views does not support feature access ?is this the fact now? If yes what can we do to publish those spatial views as feature access cabable view only to support actions over dashboard as Map services seems do not.

Example from the dashboard  I want to be able to select from a list based on attribute and once selected the map zooms to that particular geometry. 

0 Kudos
5 Replies
LanceKirby2
Occasional Contributor

I have a similar problem. I have a feature service from a spatial view and I'm trying to set up a filter in the dashboard, but once I set it in place it just removes the features from the map.

0 Kudos
UriGilad_EsriAu
Esri Contributor

Hi Ziko, Lance,

I've tried to replicate your error but overall my spatial view layer seems to work fine in the dashboard, whether it's from the feature service or the map image. I can also filter it and zoom to map item from list selection. 

I should note that I'm using SQL and not Oracle.

I'm not sure what's the difference, but here is my workflow (ArcGIS Pro 2.6, Enterprise 10.8):

1. Publish the layer from an ArcGIS Pro project as both feature service and map image (tick both boxes).

2. To do that, you must first disable the edit function of the spatial view layer feature service. You can't edit a spatial view layer so I'm not sure why you need it as a feature service - why not just publish the spatial view layer as a map image?

3. I've put the services in a web map, and then published a dashboard. As you can see below I can see the features from both the feature service and the map image service:

Make sure you can see the layer's attribute table in the web map. Could it be that you have too many features and things get stuck? Try to filter to only 100 features or so and see if there's any difference. 

Hope that helps, 

Uri


If this answer solved your question or if you found it helpful please mark it accordingly to help others who have the same question.

0 Kudos
LanceKirby2
Occasional Contributor

Thank you for doing all of that! I’m wondering if my issue is with creating the view itself.. I’m creating the view in Pro using the create spatial view gp tool. When I look at it in catalog it doesn’t have the polygon icon nor the table icon, but something in between. When I add it into a map within Pro it displays the geometry on the map, but when accessing the table I get an error “failed to retrieve table row” or something to that affect. The icon is strange and I’ve never seen anything like it before.

I have seen something about registering the view with the database, but i have never done that with other views. However, all of the other views were created through a command prompt so this is the first time trying through Pro. Can you speak to your process for creating a view??? I am using SQL as well. 

when I publish it looks fine through a web map, but if I access the attribute table and check the server logs i get an error saying something like “cannot access table, no object id; however, before publishing when I add the map I change the query through the layer properties and set the unique field as ObjectID so I’m not sure why I get that message. 

When I do a filter through the dashboard I just get a general error in the server logs like “an error occurred”, but I think that is also related to the Object ID.

0 Kudos
UriGilad_EsriAu
Esri Contributor

Hi Lance,

A properly set view layer should have the 'normal' icon. I can't see the table in ArcGIS Pro. You should, however, be able to see it in the service in an AGOL web map.

Also, are you sure the privileges on the spatial view are set correctly? You've probably came across these:

Example: Creating a spatial view in SQL Server using SQL—Help | ArcGIS Desktop 

Views in an enterprise geodatabase—ArcGIS Pro | Documentation 

My view layers were set up in SQL Studio Manager, and I wasn't the one to set them up so it's hard for me to provide more details...

0 Kudos
DavidPike
MVP Frequent Contributor

Feature services are a great frustration for me at the moment.

One workflow I read for spatial views was to publish only as a map service, then enable feature access (query only for spatial view I believe) in ArcGIS Server services site.

Permissions for feature services (query only) have been a nightmare and I have no idea why.  One way around this was to add the Rest endpoint for each feature into My content (add content - from web - arcgis server - e.g. xxxx.FeatureServer/0)

Then some feature services were present in the map, the attribute table was there, but they would never display.  A horrific workaround was to add labels to them (size 6 custom label - " ") etc.  Then they would miraculously appear.

0 Kudos