Update Failed Updates could not be sent - intermittent error on Windows 10

1145
2
04-03-2017 04:14 PM
TownsvilleCouncil
New Contributor II

Hi, We are currently using the Esri Collector mobile app (Windows 10) for data entry in the field. We have found that within the collector mobile app, if a form is opened for editing for more than approximately 45 seconds before saving, the application fails to save and instead displays the error as follows:

Update Failed
Updates could not be sent

If changes are made and saved in a shorter timeframe, the app normally saves the data without a problem.

 
Software Details:
Server: On premise Portal for ArcGIS version 10.3.1
Client: Collector version 10.4.1.0 (running on Windows 10)

 

Extra Details:

I believe the issue is related to a 401 Authorization error (as that is what I observe using the fiddler tool). If I remove the use of the web adaptor and remove security from the published service, the problem is resolved (however I need the web adaptor and security for single sign on).

 

Any suggestions are welcome, Thanks.

0 Kudos
2 Replies
JohnPlunkett
Esri Contributor

I see that you are publishing to a Portal however it could be related

I have also seen similiar behaviour if your Feature Service is published from ArcGIS Pro 1.4.1 to ArcGIS Online where Z Values are not enabled the updates fail.

Work around - republish the Service to ArcGIS Online with Z Values enabled

TownsvilleCouncil
New Contributor II

Thanks very much John, I have investigated your suggestion but I don't think it is related to my issue.

Kind Regards,

Chris.