Offline Map Area Error

568
8
01-16-2019 08:37 AM
Highlighted
New Contributor III

I am trying to use ArcGIS Online to create a 'map area' for offline use in Collector. After drawing the map area I receive an error message, "The two items must be shared the same way for this Relationship Type". When I create the map area in Collector itself there is no error, but I want to create in ArcGIS Online so I can easily allow others to use. Any suggestions?

8 Replies
Highlighted
Occasional Contributor

I am having the same problem. For me the share settings for the map and the hosted feature layer look identical.

Layer_share

map share

Highlighted
New Contributor III

Robert -- same for me.  The share settings are identical in my situation as well. 

Reply
0 Kudos
Highlighted
Occasional Contributor

Did either of you find a solution to this?  I am getting the same error.

Reply
0 Kudos
Highlighted
Occasional Contributor

I talked to ESRI Support today and they confirmed that this is a bug (BUG-000119242) in the system but it will be fixed with the next version (7.1).  The workaround is to turn off all sharing and then go in and make your Map Areas.  It worked great for me.  Make sure to turn off all sharing include the Sharing that you can do directly from the Content window.

Highlighted
Occasional Contributor

Thanks for perusing this, I got bogged down by AppStudio on another issue. I turned off sharing on the map (left the layers as is) and I was able to generate the map areas. Sharing is back on now. I will test with collector in a day or two.

Reply
0 Kudos
Highlighted
Occasional Contributor

I tried the prescribed work around and I am still getting the error. The bug report referenced above indicates a modified date for the date of this post, September 28, 2020, when accessed on the same date. Not sure what that means, but clearly there seems to be other issues with this bug. 

Reply
0 Kudos
Highlighted
New Contributor

I am having the same problem creating off-line content within the Field Maps web app beta. I also removed all sharing of my content and still received the error.

Reply
0 Kudos
Highlighted
Occasional Contributor

Make sure to send in a support ticket for this if it's still not working (and make sure to reference the BUG# I mentioned before).  Also, make sure you have the latest version of Collector.  There was an update for the Collector on  Oct 2nd (2020).