Offline Map Area Error

1826
12
Jump to solution
01-16-2019 08:37 AM
AshleyHayes2
New Contributor III

I am trying to use ArcGIS Online to create a 'map area' for offline use in Collector. After drawing the map area I receive an error message, "The two items must be shared the same way for this Relationship Type". When I create the map area in Collector itself there is no error, but I want to create in ArcGIS Online so I can easily allow others to use. Any suggestions?

1 Solution

Accepted Solutions
MatthewStull1
Occasional Contributor

I talked to ESRI Support today and they confirmed that this is a bug (BUG-000119242) in the system but it will be fixed with the next version (7.1).  The workaround is to turn off all sharing and then go in and make your Map Areas.  It worked great for me.  Make sure to turn off all sharing include the Sharing that you can do directly from the Content window.

View solution in original post

12 Replies
RobertHewlett
Occasional Contributor

I am having the same problem. For me the share settings for the map and the hosted feature layer look identical.

Layer_share

map share

AshleyHayes2
New Contributor III

Robert -- same for me.  The share settings are identical in my situation as well. 

0 Kudos
MatthewStull1
Occasional Contributor

Did either of you find a solution to this?  I am getting the same error.

0 Kudos
MatthewStull1
Occasional Contributor

I talked to ESRI Support today and they confirmed that this is a bug (BUG-000119242) in the system but it will be fixed with the next version (7.1).  The workaround is to turn off all sharing and then go in and make your Map Areas.  It worked great for me.  Make sure to turn off all sharing include the Sharing that you can do directly from the Content window.

View solution in original post

RobertHewlett
Occasional Contributor

Thanks for perusing this, I got bogged down by AppStudio on another issue. I turned off sharing on the map (left the layers as is) and I was able to generate the map areas. Sharing is back on now. I will test with collector in a day or two.

0 Kudos
Katherine_Clark
MVP Regular Contributor

I experienced this issue today in the latest version of ArcGIS Online. Your suggested solution of turning off all the sharing settings for the map and all layers within it worked for me. However, you said that the bug was fixed in version 7.1, and the current version as of today is 8.4. Could this be a new bug with repeat behavior?

RyanMikulovsky
New Contributor

I keep running into this issue too. Seems like a possible regression? It's really frustrating. My work around is to make people generate their own offline areas; my maps are too complicated to turn off sharing for every layer a practical thing. 😞 

0 Kudos
James_Whitacre
Occasional Contributor

I tried the prescribed work around and I am still getting the error. The bug report referenced above indicates a modified date for the date of this post, September 28, 2020, when accessed on the same date. Not sure what that means, but clearly there seems to be other issues with this bug. 

0 Kudos
SteveWeaver
New Contributor II

I am having the same problem creating off-line content within the Field Maps web app beta. I also removed all sharing of my content and still received the error.

0 Kudos