Map download failed - certificate for this server is invalid

3276
3
02-22-2016 12:38 PM
AlisonGaiser1
Occasional Contributor

We are just trying to get things up and running with Collector but have run into an issue that I am pretty confident has to do some sort of restriction on my network. What we want to do is use our own basemaps and provide users with the ability to work offline.

We have modified our existing cached basemap services to allow for the export of tiles.

We can see the .tpk being produced on the server when the iOS Collector app makes the request to download (found the tile package on the server in the ...\directories\arcgisoutput\external\Basemap_Ottawa_MapServer\_agsLMapCacheLFF91)

Unfortunately, when the iPad gets to the point of bringing that .tpk over to the ipad we get the following message.

Map Download Failed

Unable to download the map

The certificate for this server is invalid. You might be connecting to a server that is pretending to be "arcgisazureprod.blob.core.windows.net" which could put your confidential information at risk

Would you like to connect to the server anyway?

If I select OK, nothing happens.

In order to debug we created another collector app that uses a tiled cached service hosted by another organization. Unfortunately, when I try to download the tiles, I get the same certificate error.

I then took the ipad home and tried it to download the maps on my home network. There it all worked fine.

What I am looking for is an idea of what I need to change. Is this a firewall setting? The server that created the tile package resides inside my network. One thing is that the URL of the service is actually an F5 entry that points to two load balanced servers. But this shouldn't really have any impact since the message is received with services hosted both inside the network and outside the network.

Any thoughts and suggestions are appreciated,

     Alison

0 Kudos
3 Replies
GISSupport3
Regular Contributor

Likely something to do with the SSL certificate of the server.

There should be a 'more' button next to the error that will .... well ... have more details that may help you.

0 Kudos
AllWeatherHeather
Occasional Contributor

Our issue is similar except that we are accessing all content via ArcGIS Online. I can open the map configured for offline use without any issues but when I try to download it, it progresses about halfway then I get an untrusted server certificate error for https://tiles.arcgis.com/tiles... (service specific URL).

The base URL works correctly and I can see the SHA256 certificate on my corporate laptop but it is still causing issues during download on the device. Is there another URL or check that Collector is trying to do as part of the download process that I need to make sure is allowed in my organization?

Any help would be appreciated.

0 Kudos
IndianaUniversity
New Contributor II

Did you all ever find a solution to this problem?  It's happening to me on my iPhone.  Luckily, none of my field or office people are having the same issues as me, but I would love to know a solution so that I can take care of it in case it happens in the future.  i have attached a screenshot of what the error is saying.  I don't have an ok button or anything on my screen to bypass the error, even though it asks if I want to connect anyway

Thanks in advance for any help on this!!

Dana