Nexus 4 Sync Issue

1625
11
08-07-2014 09:07 AM
StaceMaples
Occasional Contributor III

Russell Roberts

I'm having trouble syncing an Android device running Collector. I've got a Feature Service coming out of ArcGIS Server 10.2.2. We're downloading the service, taking it into the field for offline editing and syncing back in the office. I've got 5 N4 units and various other personal devices surveyors are using. This is the only one giving me an issue. The service is using LDAP, so Collector requires signing into AGOL as well as the Service. One thing I'm wondering, does the service need to be synced using the same credentials used to download it? I don't know that that is the issue, but it strikes me a the kind of gotcha I would expect to be causing issues?

Is there a set of things I can typically do to troubleshoot syncing issues? Are there logs I can open on the device?

Stace

Message was edited by: Stacey Maples added attachments

0 Kudos
11 Replies
RussellRoberts1
Esri Frequent Contributor

I would recommend you would want to sync back with the account that downloaded the data originally. It could also be sync'ed by the server admin account. For debuging the issue enable debug server logs and try to sync the data back and you should capture the error that comes through.

0 Kudos
StaceMaples
Occasional Contributor III

So, does that mean, "Yes, it MUST be synced with the same user" or , maybe? This has implications for managing hardware and staff on surveys, so a more definitive answer would be helpful.

I've tried syncing with the server admin account with no luck.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

What error are you seeing in your debug logs?

0 Kudos
StaceMaples
Occasional Contributor III

There's alot, but no indication of a failure, that I can see. Want me to PM these? Anything sensitive in these logs? You can email me at stacey.maples@yale.edu and I will send the logs.

0 Kudos
StaceMaples
Occasional Contributor III

OK, so any other suggestions for working around this? Logs look fine. Any options for forcing a sync?

0 Kudos
StaceMaples
Occasional Contributor III

Just reiterating that it would be nice to have clarity on this:

"So, does that mean, "Yes, it MUST be synced with the same user" or , maybe? This has implications for managing hardware and staff on surveys, so a more definitive answer would be helpful."

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Yes both will work. Also check your output directory on your server right after the sync error occurs and see if the delta file exists.

0 Kudos
StaceMaples
Occasional Contributor III

Nothing shows up in the output directory.

0 Kudos
StaceMaples
Occasional Contributor III

And, by "Both will work" I assume you mean, the User who downloaded the offline map AND the Server Admin should be able to sync the data. The question remains, can anyone ELSE sync the data?

0 Kudos