iOS 7 and Collector?

10-02-2013 10:21 AM
New Contributor
Since updating my iPhone to iOS 7, I am no longer able to view any maps in the Collector app on my phone.

The collector maps all seem fine in ArcGIS online, and previously worked fine on my iPhone, but now the Collector app can't find any maps when I log in to the app.


Anyone else experiencing this?

Lucinda Dykes
Willamalane Parks & Recreation
Tags (2)
0 Kudos
8 Replies
Esri Notable Contributor
I cannot repro your issue. Have you tried signing out and signing back in and seeing the same results?

0 Kudos
New Contributor
I've tried logging in and out several times ... makes no difference.

This is true for everyone in our organization who uses Collector - and it only started when we upgraded our iPhones to iOS 7.

0 Kudos
New Contributor
Can you sign into our organization and test this? I would be happy to provide you with my log-in details (privately).

0 Kudos
New Contributor
It's not iOS7 - we did have one iPhone that wasn't updated to the new iOS, and it also doesn't display any Collector maps.

HOWEVER - all the Collector maps display in the ArcGIS app (new and old iOS).


0 Kudos
New Contributor
Here are the details on the feature service layer which is the heart of this Collector map ... is there anything that would make this not work in Collector???

Layer: Signs (ID: 84)
View In: Map

Name: Signs

Display Field: CONDITION

Type: Feature Layer

Geometry Type: esriGeometryPoint


Definition Expression: N/A

Copyright Text:

Default Visibility: true

MaxRecordCount: 1000

Supported Query Formats: JSON, AMF

Min Scale: 100000

Max Scale: 0

Supports Advanced Queries: true

Supports Statistics: true


    XMin: -1.36977888013E7
    YMin: 5469219.630099997
    XMax: -1.36819593363E7
    YMax: 5477450.935699999
    Spatial Reference: 102100  (3857)

Drawing Info:

        Simple Renderer:
        Description: Transparency: 0
    Labeling Info:

HasZ: false

HasM: false

Has Attachments: true

HTML Popup Type: esriServerHTMLPopupTypeAsHTMLText

Type ID Field:


    OBJECTID ( type: esriFieldTypeOID , alias: OBJECTID , editable: false , nullable: false )
    CONDITION ( type: esriFieldTypeString , alias: CONDITION , editable: true , nullable: true , length: 30 , Coded Values: [removed: Removed] , [failed: Failed] , [poor: Poor] , ...2 more... )
    AVGACCURAC ( type: esriFieldTypeDouble , alias: AVGACCURAC , editable: true , nullable: true )
    WORSTACCUR ( type: esriFieldTypeDouble , alias: WORSTACCUR , editable: true , nullable: true )
    COMMENTS ( type: esriFieldTypeString , alias: COMMENTS , editable: true , nullable: true , length: 50 )
    rotation ( type: esriFieldTypeSmallInteger , alias: rotation , editable: true , nullable: true )
    PHOTO ( type: esriFieldTypeString , alias: PHOTO , editable: true , nullable: true , length: 50 )
    LegacyID ( type: esriFieldTypeString , alias: LegacyID , editable: true , nullable: true , length: 30 )
    Location ( type: esriFieldTypeString , alias: Location , editable: true , nullable: true , length: 100 )
    WarrantyDate ( type: esriFieldTypeDate , alias: WarrantyDate , editable: true , nullable: true , length: 36 )
    InstallDate ( type: esriFieldTypeDate , alias: InstallDate , editable: true , nullable: true , length: 36 )
    ConditionDate ( type: esriFieldTypeDate , alias: ConditionDate , editable: true , nullable: true , length: 36 )
    Property ( type: esriFieldTypeString , alias: Property , editable: true , nullable: true , length: 30 , Coded Values: [Harvest: Harvest Landing] , [Bluebell: Bluebell Park] , [City_Cem: City Cemetery] , ...48 more... )
    GlobalID ( type: esriFieldTypeGlobalID , alias: GlobalID , editable: false , nullable: false , length: 38 )
    Type ( type: esriFieldTypeString , alias: Type , editable: true , nullable: true , length: 50 )


    Name: Signs
        Type: null
        CONDITION: null
        AVGACCURAC: null
        WORSTACCUR: null
        COMMENTS: null
        rotation: null
        PHOTO: null
        LegacyID: null
        Location: null
        WarrantyDate: null
        InstallDate: null
        ConditionDate: null
        Property: null
    Drawing Tool: esriFeatureEditToolPoint

Capabilities: Create,Delete,Query,Update,Uploads,Editing

Sync Can Return Changes: true

Is Data Versioned: true

Supports Rollback On Failure: false

Supported Operations:   Query   Apply Edits   Add Features   Update Features   Delete Features   Generate Renderer   Return Updates
0 Kudos
Esri Notable Contributor
If you and PM me the details to an account I could use to see this issue that would be great. Then I can see if I can repro this with just your org.

0 Kudos
New Contributor
Thanks, Russ.

I just sent you the log-in info.

0 Kudos
New Contributor
I think I found the issue ... which seems to be a bug.

When I change ownership of a collector map, it loses the Application Settings ... they just no longer show up.

If you look at our Collector Maps group, note the difference between Sign Collector and Sign Collector2 --- I resaved Sign Collector as Sign Collector2 and the Application Settings were restored.


Lucinda Dykes
0 Kudos