Editor Tracking

3912
8
Jump to solution
10-25-2013 10:07 AM
MichaelMatela
New Contributor
When using editor tracking, is it possible for the ArcGIS Online account login name to appear as the editor? I was assuming that this would be the case, but I am not seeing it. Your quick response is greatly appreciated.
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor
Are you using a AGOL hosted service or a ArcGIS Server service? If it is a hosted service and the service is shared to a group or its private the username will show up in the editor tracking fields. If you are using an ArcGIS Server service you will need to token secure it and set up a user & role for that will be applied against the service. When you open up the map you will have to authenticate against that layer and the user you do that with will show up in the Editor Tracking fields.

Cheers
Russ

View solution in original post

0 Kudos
8 Replies
RussellRoberts1
Esri Frequent Contributor
Are you using a AGOL hosted service or a ArcGIS Server service? If it is a hosted service and the service is shared to a group or its private the username will show up in the editor tracking fields. If you are using an ArcGIS Server service you will need to token secure it and set up a user & role for that will be applied against the service. When you open up the map you will have to authenticate against that layer and the user you do that with will show up in the Editor Tracking fields.

Cheers
Russ
0 Kudos
CollinGrove1
New Contributor
Are you using a AGOL hosted service or a ArcGIS Server service? If it is a hosted service and the service is shared to a group or its private the username will show up in the editor tracking fields. If you are using an ArcGIS Server service you will need to token secure it and set up a user & role for that will be applied against the service. When you open up the map you will have to authenticate against that layer and the user you do that with will show up in the Editor Tracking fields.

Cheers
Russ


Is there any way, currently or planned in a future update, to get any identifiable AGOL user name or id to populate a field (or editor tracking field). I don't have publisher rights for our AGOL portal, but I can publish to the server service that my AGOL map points to. Thank you!
0 Kudos
RussellRoberts1
Esri Frequent Contributor
The only way you would be able to do this is if the token secured AGS service had the same usernames as AGOL associated at the server level where you manually add them. So when the user authenticates against the layer it will be populated with the username that was used.

Hope this helps you out.
Russ
0 Kudos
MarkChilcott
Occasional Contributor III

Hi Russ,

Has this changed recently?

We have secured services from ArcGIS Server that require a username and password to connect to the REST endpoint to obtain a token.  As you indicated - the token user was the name that was written to the editor tracking layer with Collector - not the AGOL user.

Testing today would indicate the AGOL user name is now written into editor tracking field.

Cheers,

Mark

0 Kudos
MarkChilcott
Occasional Contributor III

... As it turns out - it has not changed.  The REST user is the one that gets written to the editor tracking fields.

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

Wait what? you edited in collector and the AGOL user was tracked rather than the server user name? Not possible lol

0 Kudos
JoseSanchez
Occasional Contributor III

Hello everyone,

Can you explain how to " set up a user & role for that will be applied against the service"

With the option "Users from an existing enterprise system (LDAP or Windows Domain) and roles from ArcGIS Server's built-in store"  I am able to use Active directlroy users, and when I open the map the Feature Layer shows and it is editable.

but with the option "Users and roles from ArcGIS Server's built-in store" I already created an user in ArcGIS Server, but I can not log it, it shows the error message: "Unable to access the authenticated service"

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

most likely need a CA cert or in Server admin directory set it to http only as well in your web server default site

0 Kudos